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Introduction

Created with the Standard Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web
sites

What is RightNote?

RightNote: All-in-One Notes and Information Manager
Get a grip on information overload

RightNote is an easy to use notes organizer and information manager that allows you to
store and organize different types of information in a single place and find that information
very quickly.

How can RightNote help you? 

We all have to deal with bits and pieces of information on a daily basis: phone numbers of
contacts, passwords, to-do lists, webpage snippets, research papers, accounting information,
browser bookmarks, source code snippets etc..etc.. How do you deal with it all? 

If you write things down on little pieces of paper or store this information in different files
scattered on your computer, it wont be long before you run into the following problems:
(1) It's a (huge) bother trying to find something when you need to, having to sift through
loads of information, 
(2) it's hard to backup your important information (since it is not stored in a single place)
and 
(3) it's hard to protect sensitive information (e.g. credit card details). 

RightNote solves all these problems by allowing you to store all your information in a single
place, find things ultra fast with full text search and highlighted search results, and protect
sensitive information by putting a lock on selected notes. RightNote includes different types
of notes to store different types of information. There's a word processing note for textual
information, a spreadsheet note for accounting info or any type of list, and a source code
note for source code snippets. All notes are stored in a hierarchical tree outline and can
easily be moved around and re-organized at a later point. 

The Evernote note type, allows you to store selected notes in the cloud and access them
from any device by syncing these notes with your (free or premium) Evernote account.

RightNote conveniently minimises to the system tray, waiting patiently until needed. As
soon as you need to store something, click on the RightNote icon, locate or create the
desired page, and insert the new information.

You'll start feeling different about your ability to handle the many bits of unrelated
information that you're confronted with on a daily basis. With RightNote you'll know where
to put it and where to find it!

Why is it called RightNote?

https://www.helpndoc.com/help-authoring-tool
https://www.helpndoc.com/help-authoring-tool
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Unlike other similar programs which are built around a single note type, i.e. one that
provides word processing functionality, RightNote includes different note types which
provide for a variety of functionality. Word processing, spreadsheet, syntax highlighting,
webpage and Evernote note types allow you to use the right note for the right occasion!

The next topic describes in more detail some of the features that RightNote offers to help
keep you more organised and efficient.

Created with the Standard Edition of HelpNDoc: Write EPub books for the iPad

Features
Main feature highlights include:

· Multi-page notebook. Each page contains a hierarchical
tree which can contain virtually an unlimited number of
notes. This layout offers a great amount of organisation
capability and flexibility. Each page can be devoted to a
different category, and typically you'll find you don't need
more than one or two files to organise most things in your
life!

· Multiple note types - including word processing,
spreadsheet and syntax highlighting types - allow you to
include and organise different types of information such as
general information, financial information and source code
snippets, respectively.

· Word processing note supports powerful text formatting
and layout features, including tables, hypertext link,
images and ole objects.

· Spreadsheet note supports text and cell formatting,
microsoft excel functions, cell comments, standard fill
actions such as fill up, down etc, import from .xls files and
export to .xls and .xlsx file format.

· Consistent user interface for different note types

· Support for virtual notes allows you to work on external
documents (.txt, .rtf, .rvf and .htm) all from a single
location.

· Support for link type notes allows you to open external files
and applications right from your RightNote file.

· Powerful import and export options.

· In-built full text search engine allows you to search all
notes within a file very fast.

· Highlight search term in search results.

· Support for note tags which can also be searched for via

https://www.helpndoc.com/create-epub-ebooks
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global search.

· Numerous options allow you to easily customise the
interface and behaviour of RightNote to suit your needs and
desires.

· Unicode support for most parts of the application (see
unicode help topic for exceptions).

· Automatic checking for new updates.

· Page transfer dialog makes it easy to copy or move a page
from one notebook to another

· Import files from explorer via drag and drop to either
note tree or RichView note type editor

· Internal links from one note to another note in the same
notebook

· Ability to undo all changes since last save

· Powerful and consistent print and print preview for all note
types.

· Portable version. Allows you to run the application from a
USB drive without effecting the host computer on which it
is run.

· Predefined text colors, background colors and mixed color
palettes.

· Favorite files toolbar allows for quick access to frequently
used files.

· Industry standard 128-bit encryption to help keep
selected notes or entire files secure.

· Efficient memory usage: only load notes as they are
needed.

· Fast and light database engine ensures fast data loading
and saving of even large files.

· Various compression modes keep file size small and
compact.

  

Created with the Standard Edition of HelpNDoc: Full-featured EBook editor

Unique Feature Highlights
Here are some of RightNote's unique features:

https://www.helpndoc.com/create-epub-ebooks
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· Full webpage capture, including style and layout information of the original page.
RightNote uses an advanced method to download the page very fast. Additionally saved
webpages can be edited and text can be highlighted. (Details here)

· Webpage bookmarks can be added to a note and include a thumbnail image of the
webpage like so: (Details here)

Bookmark

Title: RightNote Note Organiser Software, Create, Store and
Organise Notes

Visited on: 26 August 2014 11:50 PM

Notes: 

Source: http://bauerapps.com/rightnote/  

· Evernote integration via the Evernote note type. (Details here)

· The Folder Tree feature allows you create "hotspots" on a large tree, and thereby
locate different sections of the tree more easily. (Right click in the tree and select
"Folder")

· Advanced Page Transfer Dialog and Floating Tree allow you to easily move or copy
notes between notebooks. (Details here and here)

· And then the Side-by-Side view allows you to easily move notes between different
pages within the same notebook, or between different notebooks. (Details here)

· Setup different dictionaries for different notes.

· Special tree functions like hoist and filter. (Hoist means you can set the current note
as the base of the tree, and thereby focus on only a part of the tree at a time)

· Search as you type file searching with highlighted search results, and also multi-
notebook search (search through all RightNote notebooks at the same time).

Created with the Standard Edition of HelpNDoc: Free EPub and documentation generator

Uses
RightNote can be used as a general information manager and central place for all different
bits of information. Here are some more specific ideas that RightNote can be used for:

General

· personal information management
· personal diary or journal
· to-do lists
· scratchpad for quick notes and ideas

http://bauerapps.com/rightnote/
https://www.helpndoc.com
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· writing and structuring small articles or larger documents such as novels
· recipes
· personal contacts (addresses, telephone numbers)
· accounts, passwords, PIN numbers (file encryption is currently not supported though)
· financial records
· any kind of list or collection of items such as books, cds etc.
· templates for creating documents with a standard format
· viewing log files (use virtual nodes to view log files without having to open each file

separately)

Internet

· storing web snippets and clippings
· web based research
· email correspondence tracker
· Internet bookmarks and browsing history

Work and study

· outlines, projects
· project documentation
· reports

Created with the Standard Edition of HelpNDoc: Easy CHM and documentation editor

Terminology
For the sake of clarity a few RightNote terms and definitions are listed below:

Notebook A RightNote notebook contains a number of pages, and each page contains
its own notetree. Each notebook is saved to a single system file (that ends
with the extension ".rnt"). Hence the terms "Notebook" and "File" are used
interchangeably in this manual.

Page Each page contains a notetree on the left and editor on the right, and is
represented by a tab above them. Hence the terms "Page" and "Tab" can be
used interchangeably.

Note Each notetree contains a number of notes. A "Note" corresponds to a node
on the notetree. The contents of each note are shown in the editor on the
right.

Created with the Standard Edition of HelpNDoc: Easily create iPhone documentation

License
RightNote License Agreement

You should carefully read the following terms and conditions before using RightNote. Unless
you have a different license agreement signed by BauerApps, your use of this software
indicates your acceptance of this license agreement and warranty. If you do not accept
these terms you must cease using this software immediately.

https://www.helpndoc.com
https://www.helpndoc.com/feature-tour/iphone-website-generation
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Copyright

RightNote ("the Software") is copyright © 2008-2023 by BauerApps, all rights reserved.

Licensing terms and conditions

The Software is licensed, not sold. There is a Freeware, Standard and Professional version
of the Software. Each version has more features than the preceding one respectively. A list
of the differences between the various versions can be found in the help file.

The Freeware version may be used for both personal and commercial purposes.

The Standard and Professional versions of the Software are not free and may only be used
for evaluation purposes without charge for a period of 30 days. If you use the Standard or
Professional versions of the Software after the 30 day evaluation period a registration fee is
required. When payment is received you will be sent a registration key via e-mail. For
information on ordering a registration key please visit www.bauerapps.com. Unregistered
use of the Standard or Professional versions of the Software after the 30-day evaluation
period is in violation of U.S. and international copyright laws.

After the 30 day trial period ends, the Software will revert to the freeware version.

For the Standard and Professional versions: one registered copy of the Software may either
be used by a single person who uses the Software personally on one or more computers, or
installed on a single computer used by multiple people, but not both.

Restrictions

You are prohibited to modify, adapt, translate, reverse engineer, decompile or disassemble
the Software, or otherwise attempt to discover the source code of the Software.

Support

People who have registered the Software (i.e purchased a license key) will receive priority
support.

Distribution

You are hereby licensed to distribute free of charge, the original installation file of the
Software without any modifications. You are specifically prohibited from charging for any
such copies. You are specifically prohibited from distributing a registered version of the
Software, a registration key, or a license file that may be produced by the Software derived
from a registration key.

Disclaimer of Warranty

THIS SOFTWARE AND THE ACCOMPANYING FILES ARE SOLD "AS IS" AND WITHOUT
WARRANTIES AS TO PERFORMANCE OF MERCHANTABILITY OR ANY OTHER WARRANTIES
WHETHER EXPRESSED OR IMPLIED. NO WARRANTY OF FITNESS FOR A PARTICULAR
PURPOSE IS OFFERED. GOOD DATA PROCESSING PROCEDURES DICTATE THAT ANY
PROGRAM BE THOROUGHLY TESTED WITH NON-CRITICAL DATA BEFORE RELYING ON IT.
THE USER MUST ASSUME THE ENTIRE RISK OF USING THE PROGRAM.

Disclaimer regarding saving webpages

The Software makes no claims or guarantees as to the quality of downloaded webpages, or
to it's ability to download a specific webpage. It also makes no commitment to improving it's
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ability to download any particular webpage.

Modification
 
Bauerapps reserves the right, at its discretion, to revise these Terms and Conditions at any
time and without prior notice, and such revision shall be effective immediately upon the
posting of the revised Terms and Conditions at:
http://www.bauerapps.com/files/rightnote_terms.txt

Created with the Standard Edition of HelpNDoc: Free EPub producer

Main Topics

Created with the Standard Edition of HelpNDoc: Easily create EBooks

File functions

Created with the Standard Edition of HelpNDoc: Easily create EBooks

Basic file functions

This topic explains the basic file operations that apply to a notebook, found under the "File"
main menu item.

New Create a new file

Open Open an existing file

Save Save current changes to the file. See the "Saving and Backup" options (in the
Option dialog) to control various saving and backup options.If you want to
undo all changes since last save, use Reload.

Save As Save As can be used in 2 situations:
1. You want to create a copy of an existing file. You select a new file name and
then save.
2. You don't want to save changes to the current file (for some reason), but
you still want to save the new changes. In this case you can save to a
different file.

Close Close the current file. If changes have been made you will be prompted to
save them before closing the file, unless "Auto save when close file" has been
checked in the "Saving and Backup" options. In this case you won't be
prompted.

Reload In some cases you may want to undo all changes that you've made to a file
since the last save. You could just as easily close the file (without saving) and
then re-open it. The Reload operations allows you to do this in one simple
step.

The "File Cleanup" action is described in detail in the Protection: Important Information
topic.

Created with the Standard Edition of HelpNDoc: Free HTML Help documentation generator

https://www.helpndoc.com/create-epub-ebooks
https://www.helpndoc.com/feature-tour
https://www.helpndoc.com/feature-tour
https://www.helpndoc.com
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Import/Export

Created with the Standard Edition of HelpNDoc: Full-featured Kindle eBooks generator

Importing

Import Methods

· File/List of Files
· Folder and all subfolders and files: Specific settings to control this process are found

in the Options dialog under the Import section.
· Scrapbook Archive: Scrapbook is a popular Firefox add-on that stores webpages to a

location on your hard-drive. When importing such an archive select the root folder of
the archive, i.e. the folder that contains the "scrapbook.rdf" file.

· Keynote file

Notes for when importing files/list of files

RightNote allows you to import existing data from a variety of different file formats. Below
is a table that describes what type of note will be created from what type of source file.

File Extension Imported note type

.txt Plain note

.rtf RichEdit note

.rvf, .htm, .doc RichView note

.xls, .csv Spreadsheet note

all other text files Syntax highlighter note

binary files binary files cannot be imported and will be skipped

When importing you can choose whether to import the file(s) as:
· A standard note - copies the file data into a new note
· virtual note - creates a "virtual link" to this file. When you edit this file in RightNote

then it is actually editing this external file.
· link - creates a shortcut to this file. When you click on "launch" then this file will be

opened by it's associated application.

See more about virtual notes here

There is also support to import KeyNote files directly. Simply select the file from the import
dialog, as you would any other file.

Note 1:
Although you can import Microsoft Word (.doc) and Microsoft Excel files (.xls), you can not
make them virtual.

Note 2:
MS Excel needs to be installed in order to import images from an excel (.xls) file.

Tip:
You can easily import files by drag 'n drop from Windows Explorer.
1.   First make sure that RightNote is NOT minimised to the system tray, i.e. the

application bar is visible in the task bar.

https://www.helpndoc.com/feature-tour/create-ebooks-for-amazon-kindle
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2.  Select the desired files in Windows Explorer.
3.  Left click and then drag them over the RightNote application bar (RightNote will

maximise) and then to the desired destination tree or node - then drop (release
mouse).

Created with the Standard Edition of HelpNDoc: Create cross-platform Qt Help files

Import Options

When importing, the Import Options Dialog prompts in what way you want the files to be
imported:

Standard The content of the imported file is added and converted to the best
matching note type. E.g. An Excel file (.xls) will be added as a spreadsheet
note, a rtf file will be added as a Rich Edit note.

Virtual Note Add a note that links to the external file, and be able to edit it directly from
within RightNote. To be used for txt, rtf, rvf and source code files:
- A txt file will be imported as a Memo note.
- A rtf file will be imported as a Rich Edit note.
- A rvf file will be imported as a Rich View note.
- Other plain text files will be imported as a Source Code note.

Attachment Create a copy of an external file and save it into the database. Can handle
any file type. Editing an attachment only modifies the internal copy, not
the original file.

Link to File Link to an external file. If supported, contents of the file will be indexed
and made searchable.

Created with the Standard Edition of HelpNDoc: Free Web Help generator

Exporting

The export dialog allows you to control which notes will be exported, and by what method.

Notes can be exported either individually or merged into a single output file. Switch
between the relevant tabs on the pagecontrol to select which export method you want to
use.

When exporting files individually the following output formats are available:

Note type Export formats

Plain note .txt

RichEdit note .txt, .rtf, .htm

RichView note .txt, .rtf, .htm, .rvf, .doc, .docx

Spreadsheet note .xls, .csv

Syntax highlighter note The output file extension is specified for each note
within the note editor

The "export file format" combobox controls the output format for RichView type notes. To
set the output format for RichEdit and Spreadsheet type notes click on the "More..." button.

https://www.helpndoc.com/feature-tour/create-help-files-for-the-qt-help-framework
https://www.helpndoc.com
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Merged file export formats

When merging all notes to a single output file, all notes are merged internally to a RichView
type note and then exported. In this case possible export formats
include: .txt, .rtf, .htm, .rvf, .doc and .docx.

Note indenting for merged file output

When you export to a single merged file (or print), there is an option to indent note content
according to the relative level of the notes in the tree. To enable this option, go to the
Export Style Definitions (Tools -> Definitions -> Export Style Definitions), and check the
"indent each note..etc." option. Note that this same option applies when printing multiple
notes.

Note:
To export to .doc format, the free Office Converters pack may need to be installed on the
computer (even if you have MS Word installed). The Office Converters pack can be
downloaded from here:
http://www.trichview.com/resources/thirdparty/FileFormatConverters.exe

If you have installed the converters pack and receive an "error code -1" when exporting to
.doc, please try to uninstall the compatibility pack, and then re-install it.

Note 2: 
MS Word is not required to export to .docx format

Created with the Standard Edition of HelpNDoc: Create help files for the Qt Help Framework

HTML header & footer options

When exporting a document to html format (including export to Webbook format) you can
include a custom header and footer for each document.

The settings to control this are available in the "HTML header/footer options" dialog, which
can be accessed
· in the Export dialog, via the "HTML Options" button,
· in the Export to Webbook dialog, via the "Header/Footer options" button.

In the edit box for Header/Footer file name, you can specify just a filename (without a
path), in which case the program will look for this file in the settings folder (see Help-
>Open Settings Folder). Otherwise, you can specify a full file path to any file on your
system.

You can place any valid html into this file. Bear in mind the following points:
· The file should be utf8 encoded.
· The file should not include any <html> or <body> tags, i.e. it should just be a html

snippet, not a full document.
· You should include css styles within an inline style element.
· The text "#caption#" (without quotes) will be replaced with the current note caption.

http://www.trichview.com/resources/thirdparty/FileFormatConverters.exe
https://www.helpndoc.com/feature-tour/create-help-files-for-the-qt-help-framework
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Created with the Standard Edition of HelpNDoc: Write EPub books for the iPad

Export to Webbook

The Export as Webbook action (under File) allows you to export your notes as a webpage
(html) based notebook in both web and mobile formats.

All you need to do is set the base export folder. This folder is not specific for the current
notebook. Instead, all notebooks will be exported to this folder and RightNote will
automatically create a subfolder for each notebook based on the notebook name.

For example, if you choose to export to a folder "C:\My Webbooks", RightNote will create a
subfolder called "notebooks", and 2 loader files: web.html for web version and mobile.html
for the mobile version. Each notebook that you choose to export, will be exported in a
subfolder under the "notebooks" folder. (Every time you export a notebook, the loader files
are updated based on the subfolders present under the notebooks folder.)

To view/open the webbook, double-click or open the appropriate loader file.

The other options available on the Export to Webbook options dialog are straightforward:
You can select a theme for web and mobile versions and also choose to include protected
notes or not in the export.

Mobile scaling
For the mobile version, you may also choose to modify the scaling settings: i.e. if the user
can scale the content, what the initial scale of the content should be and the maximum
scale. The optimal options may depend on your mobile device and it's screen resolution.

Viewing notebooks on your mobile device
Once you have exported the notebook to the computer file system, you can transfer the
files to your mobile device. As a suggestion, you can create a folder on the sdcard called
"webbooks" (at the root level). On an Android device, to view the notebooks, open your
browser and then point it to:
file:///sdcard/webbooks/mobile.html to get started.

https://www.helpndoc.com/create-epub-ebooks
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Sample webbook in web format

Sample webbook in mobile format

Created with the Standard Edition of HelpNDoc: Full-featured EPub generator

Printing

The print dialog works similarly to the export dialog, allowing you to select which notes you
want to include in the print job, and various options to apply to the print job.

When printing a range of notes, the following useful options apply:

https://www.helpndoc.com/create-epub-ebooks
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· Indent each note according to it's level in the tree. Note: This option is set in the Setup
Export Styles dialog.

· Include Tree Path. If checked, the relative tree path of the note will be included either
before the note caption or after it (depending on selected option), as shown in the
following image:

Note that the page margins, header and footer settings are available at File -> Page Setup -
> RichView.

Besides the special header and footer characters mentioned there (&p, &P etc.), you can
also use &F which will be replaced with the notebook filename.

Note:
It should be kept in mind that the printing engine works differently depending on if only
one or more than one note is being printed. 

If one note is being printed then Syntax highlighter and Spreadsheet type notes use their
own specialised printing engine which offers more options for these types of notes. For
example for a Syntax Highlighter type note you can include line numbers, and include
advanced header and footer options. For Spreadsheet type notes you can select whether to
include grid lines, include spreadsheet header cells and repeat fixed rows and columns.

Hint:
It's always a good idea to first run a print preview to see what the print job will look like,
before you do the actual printing.

Created with the Standard Edition of HelpNDoc: Write EPub books for the iPad

Printing or exporting an outline

When you print or export a tree that contains an outline note, the outline note is
considered as a single note, and the text (or content) of this note is indented corresponding
to the indentation of the notes in the outline. Note content is added "inline" in a smaller
font. Attachment notes in the outline will be skipped.

https://www.helpndoc.com/create-epub-ebooks
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However, if the current note in the main tree is the outline note, then you have the option
to print/export the outline as if it was a main tree, handling each note individually. To
achieve this, in the Print/Export dialog select (or check) the option "Start in the outline
tree". Note, this option is only visible when the current note in the main tree is an outline
note.

Created with the Standard Edition of HelpNDoc: Create help files for the Qt Help Framework

Favorite notebooks

The favorite notebooks dialog allows you to setup toolbar items for easy access to
frequently used files.

1. You can double click on a file in the "recent files" list to add it to the favorites list.
2. The "Separator" option determines whether separator items are included between each
toolbar item or not.

Tip:
The favorites toolbar can be docked to the left side of the main application window. To do
this: click - drag to left - release when in correct position.

Created with the Standard Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web
sites

Favorite notes

The favorite notes feature allows you to create a list of favorite notes from different
notebooks for quick access.

To add a note to the list, right-click in the tree, go to "More...", then click on "Add to
Favorite Notes".

To bring up the Favorite Notes dialog, press Ctrl+F12 (default hotkey). The notes are sorted
alphabetically. You can simply type the first letter of the note to select it. If two notes start
with the same letter, pressing the letter again will move to the next note (and so on). 

Once the desired note is selected, pressing "Enter", will close the dialog and either take you
to that note (if it exists in the currently open notebook), or bring up the external note
viewer (if the note exists in a notebook that is not currently open). You can also double
click on the note to open it.

If a note caption has subsequently been changed or the note was moved to a different
location in the notebook, you should click on "Refresh" to update the note captions and
location information.

Created with the Standard Edition of HelpNDoc: Easily create CHM Help documents

Maintenance

Created with the Standard Edition of HelpNDoc: Free EPub producer

Repairing a corrupt database (general information)

Under normal circumstances, you do not need to concern yourself with the items under the
Maintenance menu. RightNote uses an industry standard database engine called SQLite
(www.sqlite.org), which is highly resistant to corruption and ensures that your data is kept
in a valid and correct state during normal application use.

https://www.helpndoc.com/feature-tour/create-help-files-for-the-qt-help-framework
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https://www.helpndoc.com/help-authoring-tool
https://www.helpndoc.com/feature-tour
https://www.helpndoc.com/create-epub-ebooks
www.sqlite.org


RightNote

20 / 114

Nevertheless, data corruption can occur in rare situations, and in such cases the tools in the
Maintenance section will be of great help.

So firstly... when does data corruption occur?

Causes of database corruption

In our experience, the most common causes are:
· Cloud syncing software, and

· Hard drive failures, sudden system shutdowns etc..

Cloud syncing software works fine in most cases, however in some cases there can be a
hiccup in the sync process - especially if RightNote and the cloud service are trying to
access the database at the same time, and as a result, a database can become corrupted.
See the Recommendations and best practices when using cloud services topic, for relevant
advice.

As mentioned, hardware failures and sudden system shutdowns can also result in database
corruption. Both of these causes underscore the importance of having a backup mechanism
in place for your data files, and if possible, using a UPS (Uninterruptible Power Supply)
power supply.

Degrees of damage

When database corruption occurs, it can be small or large. If small, typically you will still be
able to open your RightNote file, and perform usual operations such as adding notes,
performing searches, etc. However, when you try to perform a File Cleanup, then the
program reports an error. In other cases, where there is a larger degree of damage, you
may not even be able to open the RightNote file.

What Repair Database accomplishes

The "Repair Database" action comes to the rescue, and can repair a damaged database.
However it is (very) important to realise that the  repair action cannot magically restore
damaged data. All it does, is "cut away" the damaged parts of the database, thus leaving
the rest of the database in a valid and working state. That being the case, you will
understand, that sometimes it is preferable to revert to an existing backup, instead of
repairing the database. Obviously if there are no backups available, or if you have done a
sizeable amount of work since the last backup, you will want to try the Repair Database
action.

After running the Repair command, you will want to check if there are now any notes that
have been left without content (i.e. the damaged content was removed, and now there is
just a note in the tree, but no associated content). If that is the case, then those notes
should be removed, or more optimistically, you can try to locate those specific notes in a
backup copy. A list of such notes is provided by the "Show Notes without Content" action
(under File->Maintenance).

Note: 
When a database is repaired, the existing file is renamed to MyFile_corrupt.rnt, and a new
repaired file is created with the original filename. As such, it is important that the
RightNote file is not in use when performing the Repair Database command. 

Disclaimer
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In our experience, the Repair Database method used has helped repair the corrupt
databases reported by our users. However, there is no guarantee that this method will work
in all cases of database corruption.

See the 3 ways to deal with a corrupt database topic, for additional information.

Created with the Standard Edition of HelpNDoc: Create help files for the Qt Help Framework

Using the repair database tool

To repair a corrupt database, simply click on File -> Maintenance -> Repair Database.

If a file is already open, then the repair action will apply to that file. If no file is open, then
you will be prompted to select a file.

If the selected file is not corrupt, then the program will notify you and exit the repair
operation.

See the 3 ways to deal with a corrupt database topic, for additional information.

Note:
When a database is repaired, the existing file is renamed to MyFile_corrupt.rnt, and a new
repaired file is created with the original filename. As such, it is important that the
RightNote file is not in use when performing the Repair Database command. 

Note 2:
If the file is very large (for e.g. hundreds of MB's, or close to a GB), then that may be more
than the repair tool can handle, and the tool will abort due to insufficient memory. In that
case you will need to rely on the other ways mentioned in the above linked topic, to deal
with a corrupt database.

Created with the Standard Edition of HelpNDoc: Easy EPub and documentation editor

Folder Health Report

For your convenience, the Folder Health Report tool, can examine an entire folder and
give a report of the status of all RightNote files contained therein.

Possible status values and required action include:

Status Required action

All Good Nothing need be done.

Out of date Old database format. The file needs to be updated to the
latest version. Simply opening the file in RightNote will do
this.

Corrupt Database corruption detected. Perform a database repair.

Problem detected with the
Full Text Index

Perform a File Cleanup.

Notes without Content Some notes do not have associated content. This can occur
after a database repair action has been performed. Run the
"Show Notes without Content" action (under Maintenance),
and then remove these notes from the database.

https://www.helpndoc.com/feature-tour/create-help-files-for-the-qt-help-framework
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Error obtaining report Some unknown error occurred while trying to obtain the
report. Please report the problem to support.

If you right-click on the report list, various actions are available, such as Open, Update and
Repair.

Created with the Standard Edition of HelpNDoc: Free Qt Help documentation generator

Dealing with a forgotten note password

As we mention in the Protecting your notes section, RightNote does not keep any record of
a note password used to protect specific notes and pages in a RightNote file. 

So what happens in such a case where the note password was indeed forgotten? 

Well, you may ask, so what? Why is that a problem? (I.e. besides not being able to view the
protected notes is there any other problem?). The problem is that various database
operations (e.g. File Cleanup) require that the note password be present, so not knowing
this password, can potentially be a problem for the database as a whole.

To help deal with such a situation:

· The "Show Protected Notes" action will show a list of all protected notes. Using this
list, you can locate and then remove all such notes from the database. It could be that
in fact there are no specifically protected notes...

· Once there are no protected notes in the database, then you can go to File -> File
Properties, and in the Protection section, there will be a button available that allows
you to remove the existing note password, without even knowing what it is.

Created with the Standard Edition of HelpNDoc: Full-featured multi-format Help generator

Update links

Since version 4.8 RightNote uses a new format for internal links. One of the problems with
the old format was that if a target note was moved to a different page, then the link would
not work. This problem does not affect the new format.

To update links from the old format to the new format, click on:

File -> Maintenance -> Update Links.

Once the links have been updated, the "Update Links" action is no longer shown under the
Maintenance menu. This action should be executed for each notebook containing internal
links.

Created with the Standard Edition of HelpNDoc: Free PDF documentation generator

Different note types

Created with the Standard Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1
single source

Editor types

RightNote includes 11 different note types. So when and why would you want to use a
particular note? This topic briefly describes the main advantages of each different note

https://www.helpndoc.com
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type:

Plain note

· best used for plain text notes, where no formatting is required or desired.
· note data contains no extra formatting information so uses up least amount of disk

space

RichEdit note

· based on windows RichEdit control (as found in WordPad)
· provides text formatting, ability to insert OLE objects and images (no support for tables)
· provides better handling of OLE objects compared to RichView note (can resize the ole

object)
· provides zoom facility (you can enlarge zoom factor of editor with mouse left click and

wheel scroll)

RichView note

· provides best word processing capabilities, including support for tables, images, OLE
object, hypertext links

· exports natively to .rvf file type (i.e all data will be preserved if you export to this
format. If you export to other formats some formatting may be lost)

· Default note type (this can be changed in Options -> Note settings)

Syntax highlighter note

· most suited for source code snippets
· supports most common programming languages such as c++, c#, pascal, java, visual

basic, as well as xml, html, css.
· all lexers can be customised via Tools -> Highlighter settings

Spreadsheet note

· best suited for tabular data
· supports large percent of microsoft excel functions (see next topic for details)
· can import from and export to excel file format (.xls)
· supports sort function to sort data

Webpage note

· Store entire webpages for future reference
· Stored webpages can be highlighted and edited

Evernote note

· These notes can be synced with Evernote
· Supports all standard Evernote elements such as images, attachments, checkboxes (to-

dos) and locks

Attachment note

· Attach any file into the database.
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· Common file formats (e.g. .doc, .xls, .pdf) are indexed in the Pro version.

Link note

· Create a link to any file for quick access to that file

Outline note

· The outline note is essentially a tree within a tree.
· Each note in the tree has it's own content.
· Great for outlining ideas

Task List note

· The task list is the same as an outline except that it has checkboxes visible.
· Great for keeping track of a hierarchical list of tasks.
· More task related features are planned for future versions.

Created with the Standard Edition of HelpNDoc: Easily create Web Help sites

RichView note type

Some tips for using the RichView note type:

General information on hyperlinks

For general information on hyperlinks see the hyperlinks topic.

Scanning hyperlinks

If you paste links (e.g. text containing "www...." or "http://..." or mailto@...") into a note
from a plain text or RTF source then they will not be "active" i.e. they will appear as normal
text. Typed in links will also appear as normal text if you have the "auto-detect url" option
unchecked (Options->RichView settings).

You can detect/activate such links with the "Scan for links" action under the Edit menu.

Inserting an icon from the Icon database

You can insert an image from the icon database into a RichView note, however note that
you can only insert icons from the Custom Database. The System Database is mostly
made up of propriety (commercial) icons that do not allow end users to use these icons in
their own documents, hence only the Custom Database can be used for this purpose. (So
System Database icons are only used within the application for things such as tags, tree
icons, etc.)

Tip:There are a large amount of freeware icons (and icon sets) available on the internet,
that will allow you to fill your Custom Database with a large variety of icons for your own
personal use.

Created with the Standard Edition of HelpNDoc: Write eBooks for the Kindle

Spreadsheet note type

Created with the Standard Edition of HelpNDoc: Create cross-platform Qt Help files
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Some usage tips

Some tips for using the spreadsheet note type:

Comments

You can use the "edit comment" command to add, edit or delete a comment. To delete a
comment, edit it and clear all comment text.

Sorting by multiple columns

To sort by multiple columns, sort each column in reverse order. For example, if you want to
order by columns titled "surname, first name, age" then sort the columns one by one in this
order: age, first name, surname.

Moving columns

You can move entire columns (right or left) and rows (up or down). You don't need to select
the entire row/column. The currently selected cell determines which row/column will be
moved. You can also move multiple columns or rows at the same time. To do this, select a
range of cells, and then click on the desired move action.

Format string

The format string determines how the cell's actual "Value" is formatted for display in the
spreadsheet. Some common examples follow:

Information type Format string Entered value Displayed value

Date dd/mm/yyyy 2008/10/01 (correct
method to enter date
values depends on
regional settings)

01/10/2008

Currency $ 0.00 64 $ 64.00

Numeric type 0.00 0.66666666 0.67

Further examples can be found in excel documentation or in excel format cells dialog.

Hyperlinks

Double-click launches URL.

Created with the Standard Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web
sites

Supported spreadsheet functions

Cell references, arithmetic operations, and syntax rules in formulae are identical to
Microsoft Excel ones. The supported functions are identical to Microsoft Excel functions. You
may use the Microsoft Excel help system as a reference on formulae and functions.

List of supported excel functions:

ABS
ACOS
ACOSH
ACOT

https://www.helpndoc.com/help-authoring-tool
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ACOTH
ADDRESS
AND
AREAS
ASIN
ASINH
ATAN
ATAN2
ATANH
AVEDEV
AVERAGE
AVERAGEA
AVERAGEIF
AVERAGEIFS
BASE
BETA.DIST
BETA.INV
BETADIST
BETAINV
BINOM.DIST
BINOM.DIST.RANGE
BINOMDIST
CEILING
CEILING.MATH
CEILING.PRECISE
CHAR
CHIDIST
CHIINV
CHISQ.DIST
CHISQ.DIST.RT
CHISQ.INV
CHISQ.INV.RT
CHOOSE
CLEAN
CODE
COLUMN
COLUMNS
COMBIN
COMBINA
CONCATENATE
CONCATENATE
CORREL
COS
COSH
COT
COTH
COUNT
COUNTA
COUNTBLANK
COUNTIF
COUNTIFS
COVAR
COVARIANCE.P
COVARIANCE.S
CSC
CSCH
DATE
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DATEVALUE
DAY
DAYS
DAYS360
DECIMAL
DEGREES
DEVSQ
DOLLAR
EDATE
EOMONTH
EVEN
EXACT
EXP
EXPON.DIST
EXPONDIST
FACT
FACTDOUBLE
FALSE
FIELD
FIELDPICTURE
FIND
FIXED
FLOOR
FLOOR.MATH
FLOOR.PRECISE
FORECAST
FORMULATEXT
FV
GAMMA
GAMMA.DIST
GAMMA.INV
GAMMADIST
GAMMAINV
GAMMALN
GAMMALN.PRECISE
GAUSS
GEOMEAN
HLOOKUP
HOUR
HYPGEOM.DIST
HYPGEOMDIST
IF
IFERROR
IFNA
INDEX
INDIRECT
INT
INTERCEPT
IPMT
ISBLANK
ISERR
ISERROR
ISEVEN
ISLOGICAL
ISNA
ISNONTEXT
ISNUMBER
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ISO.CEILING
ISODD
ISOWEEKNUM
ISTEXT
LARGE
LEFT
LEN
LN
LOG
LOG10
LOOKUP
LOWER
MATCH
MAX
MAXA
MEDIAN
MID
MIN
MINA
MINUTE
MMULT
MOD
MONTH
MROUND
N
NA
NORM.DIST
NORM.INV
NORM.S.DIST
NORM.S.INV
NORMDIST
NORMSDIST
NORMSINV
NOT
NOW
NPER
NPV
ODD
OFFSET
OR
PEARSON
PERCENTILE
PERCENTILE.EXC
PERCENTILE.INC
PERMUT
PI
PMT
POISSON
POISSON.DIST
POWER
PPMT
PRODUCT
PROPER
PV
QUARTILE
QUARTILE.EXC
QUARTILE.INC
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QUOTIENT
RADIANS
RAND
RANDBETWEEN
RANGE
RANK
RANK.AVG
RANK.EQ
REPLACE
REPT
RIGHT
ROUND
ROUNDDOWN
ROUNDUP
ROW
ROWS
RSQ
SEARCH
SEC
SECH
SECOND
SIGN
SIN
SINH
SKEW
SKEW.P
SLOPE
SMALL
SQRT
SQRTPI
STDEV
STDEV.P
STDEV.S
STDEVA
STDEVP
STDEVPA
STEYX
SUBSTITUTE
SUBTOTAL
SUM
SUM
SUMIF
SUMIFS
SUMSQ
SUMSQ
T
T.DIST
T.DIST.2T
T.DIST.RT
T.INV
T.INV.2T
TAN
TANH
TDIST
TEXT
TIME
TIMEVALUE
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TINV
TODAY
TRANSPOSE
TRIM
TRUE
TRUNC
TRUNC
UPPER
VALUE
VAR
VAR.P
VAR.S
VARA
VARP
VARPA
VLOOKUP
WEEKDAY
WEEKNUM
WEIBULL
WEIBULL.DIST
XOR
YEAR
YEARFRAC

Created with the Standard Edition of HelpNDoc: Easily create PDF Help documents

Default settings

Default font setting

There are some global spreadsheet settings that are found in the Options dialog (under
Tools->Options->Editors->Spreadsheet), and then there are also some default settings
which apply for each spreadsheet (under Format->Default Settings).

The global "Default Font" setting only applies to newly created spreadsheets, but it does not
affect existing spreadsheets.

The default font for each spreadsheet can be set in the Default Settings dialog (under
Format menu).

Note: With regard to the default font setting, only font name and font size are used. Other
attributes are not included.

Default font color

You may notice that the default text color in the spreadsheet is somewhat lighter than pure
black. This is called "Default color", and is relevant to the fact that the spreadsheet can be
used with both a light and dark theme. When using a light theme, the default text color,
will show as dark text, but when using a dark theme, it will show as light text (close to
white). However black text, will always show as black whether using a light or dark theme.
If desired you can check the option in global settings to display the default color as pure
black (for a light theme, and conversely, as pure white when using a dark theme).

Created with the Standard Edition of HelpNDoc: Easy EBook and documentation generator

Resetting old properties

The "Reset Old Properties" action is primarily intended to fix a number of formatting issues
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that can arise after an old spreadsheet note (i.e. created prior to v4.3) is upgraded to the
new spreadsheet format.

The following issues will be fixed:

· A subtle silver border will be removed from active cells

· Cell text will be aligned to bottom

· Row/Col text alignment will be set to bottom

· All rows will be reset to the default row height

· All black fonts will be set to "default" color

· All fonts will be changed to the default font

Take note that default row height and default font are set in the Default settings dialog
(mentioned in the previous topic). Hence it is advised that you first set the default font and
row height, before executing the "Reset Old Properties" action. Each item is listed in the
dialog, and will only be applied if checked.

This action can also be applied in other cases where you want to "reset" the spreadsheet
formats so as to achieve a consistent appearance.

Created with the Standard Edition of HelpNDoc: Easily create PDF Help documents

Reducing fonts

In some cases you will want to reduce the number of fonts used in the spreadsheet. This
action helps you achieve that.

Note: The action only modifies font name and size properties. It does not affect other font
attributes such as bold style or color.

Created with the Standard Edition of HelpNDoc: Free help authoring environment

Showing format information

The "Show Format Info" function (under the Format menu) is an advanced function that can
give you some extra insight as to what format settings are active for a given cell.

It shows the font and format settings for:
· The spreadsheet (def)

· The current column (col)

· Row

· and Cell.

Settings take precedence in the following order: Cell, Row, Col, and Default.

"nil" indicates that the item has not been set.

Created with the Standard Edition of HelpNDoc: Easily create Web Help sites

Printing spreadsheet notes

When you select to print a single spreadsheet note, a specialized print dialog is used specific
for spreadsheet notes. This dialog provides a number of advanced options such as show or
hide grid-lines, show or hide column headings and live adjusting of page margins. It also
provides a lot of flexibility in allowing you to view multiple pages side by side or in different
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orientations.

However, when you select to print multiple notes, for example two spreadsheets or a
spreadsheet and a richview note, then the default Richview print engine is used. In this
case the spreadsheet is converted to a richview note (for printing purposes only) using the
settings found under Tools->Options->Editors->Spreadsheet.

(There is an option to use the Richview engine when printing a single spreadsheet note,
however usually you will want to use the specialized print dialog).

Created with the Standard Edition of HelpNDoc: Easy CHM and documentation editor

Attachment note type

The attachment note type allows you to store any type of file in a RightNote database. For
example you can store MS Word documents, Excel files and PDF Documents. If supported,
the contents of the file will be indexed and made searchable.

Currently the following file types will be indexed:
txt, rtf, htm, html, doc, docx, xls, pdf.

You can open/view the file by clicking on the Open File link in the viewer. This will open
the file with the default associated application for the file type, for example and xls file will
be opened by MS Excel (if it is installed); a doc file will be opened by MS Word.

Adding/Inserting an attachment
You can add an attachment by: (i) clicking on Add Child/Sibling->Attachment, (ii) Drag-drop
a file(s) from Windows Explorer in a RightNote tree, (iii) Use File- >Import->File / List of
Files, and then select to import as an attachment.

Note:
When you open an attachment, you are viewing a copy of the original document. If you
make changes to the attachment, this will not affect the original source document.

Note 2:
The main purpose of the "View Text" link (and number of chars) in the attachment
viewer/panel is to give visual feedback of whether an attachment/link has been indexed,
and if the indexing is working correctly. The text index is "raw data" and should not be
expected to be in any particular format. In some cases however, it will be formatted close to
the original (e.g. for word documents).

Created with the Standard Edition of HelpNDoc: Full-featured EPub generator

Link note type

The link note type allows you to create a link to any type of file on your computer. For
example you can create links to MS Word documents, Excel files and PDF Documents. If
supported, the contents of the file will be indexed and made searchable.

Currently the following file types will be indexed:
txt, rtf, htm, html, doc, docx, xls, pdf.

Note:
A link note does not store the actual contents of the file in the RightNote database. It
simply points to a file on the file system (or internet url). If you open the link, you will be
opening the source file pointed to by the link url.

Note 2:

https://www.helpndoc.com
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The main purpose of the "View Text" link (and number of chars) in the attachment
viewer/panel is to give visual feedback of whether an attachment/link has been indexed,
and if the indexing is working correctly. The text index is "raw data" and should not be
expected to be in any particular format. In some cases however, it will be formatted close to
the original (e.g. for word documents).

Created with the Standard Edition of HelpNDoc: What is a Help Authoring tool?

Webpage note type

It is possible to save webpages into RightNote as a "Webpage note type". You do this by
pressing the Webpage capture hotkey (Default Ctrl+Win+W), while you are viewing the
webpage in the browser. (Note: Available in the Pro version only)

You can change this hotkey under Options->Global Hotkeys. The following browsers are
supported: Internet Explorer, Firefox, Chrome and Opera.

As you press the hotkey, a progress indicator will popup indicating the progress of the
download. When the download completes, a new note will be added in much the same way
as a new clip is added. (see Tools->Clipper Options).

You can cancel the download by pressing the "X" at the top right of the progress popup. You
may need to wait a while for the download to cancel itself.

(Special note for Google Chrome browser: For the webpage capture feature to work, .NET 4
must be installed on the computer. See here for more info.)

Question: Why does the progress indicator suddenly drop down?

You may notice that sometimes the progress indicator goes up, and then suddenly drops
down before it starts going up again - particularly towards the start of a download. The
reason for this is that as the webpage is being downloaded, at some points more required
links are found, and so the progress indicator drops down.

Current limitations in webpage capture capabilities

Currently the download engine works independently from the browser - i.e. no content is
obtained directly from the web browser. As a result of this, pages that are only
obtained/arrived at after logging in to a website cannot be captured. (In this case, it's better
to use the clipper tool). If you try to download such a page, you are likely to see that the
login page was captured - instead of the one you were viewing. There are plans however for
browser integration, in which case this limitation will be removed.

IMPORTANT DISCLAIMER REGARDING SAVING WEBPAGES

The program makes no claims or guarantees as to the quality of downloaded webpages, or
to it's ability to download a specific webpage. It also makes no commitment to improving it's
ability to download any particular webpage.

Note: This does not mean that we will not continue to improve the quality of our download
engine over time. The internet uses a vast number of technologies and therefore no
guarantees can be made as to the quality of a particular download/webpage capture.
However, in general webpage capture quality should be good for simple or medium
complexity types of webpages. For more complex webpages, results may be more variable.

Created with the Standard Edition of HelpNDoc: Free help authoring tool
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Chromium webpage viewer

RightNote now includes a Chromium based webpage viewer that enables you to view
advanced and modern webpages correctly (saved by the Webpage note). Technically
speaking, it is using the WebView2 control provided by Microsoft, which requires at least
Windows 10, and will be installed automatically by the latest Windows updates. Additionally,
this control is updated automatically by Windows update, and so allows for the RightNote
installation file to be a lot smaller.

If this component is not installed on your system, RightNote will give you a corresponding
error message, in which case you need to install the component manually from this
webpage: Microsoft WebView2 Download. (This will install the Evergreen Standalone
version of the WebView2 control).

Microsoft License

Use of the WebView2 control is governed by Microsoft's license agreement. If you go to the
above link, and click on "Download WebView2", you will be presented with the full license.
The following is a short extract: WebView2 collects a set of optional and required diagnostic
data to keep WebView2 secure and up to date, diagnose issues, and improve WebView2.
Additionally, WebView2 follows the privacy standards that are outlined in Microsoft Edge
Privacy Whitepaper. As such, WebView2 data collection follows the same strict standards as
Microsoft Edge. Please see below, information regarding Microsoft Defender SmartScreen.

Editor Mode

You can activate edit mode with Ctrl+E, or by clicking the menu button under the Edit
menu. The editor is not intended to provide advanced editing capabilities, such as different
fonts or tables. Instead, it is intended to allow highlighting of specific text on the  webpage,
or making small changes to the formatting and text. As such it allows to apply basic styles
such as bold, italics or underline, and also highlight text, using the foreground/background
color palettes.

Options

The chromium viewer can be disabled in the application options (under Tools->Options,
Editors->Webpage), in which case the viewer based on Internet Explorer will be used.

There is also an option to enable/disable Microsoft Defender SmartScreen ("SmartScreen").
SmartScreen is a security feature that is enabled by default, to help users safely browse the
web. When this option is enabled, the WebView2 control collects and sends the user's
information to Microsoft as disclosed in Microsoft Privacy Statement and in SmartScreen in
Microsoft Edge Privacy Whitepaper.

Besides this RightNote setting, there is also a Windows setting that can be found in
Windows Settings->Reputation Based Protection: SmartScreen for Microsoft Edge. If this
setting is disabled, then the RigthNote setting will be ignored.

Cache

A cache for the WebView2 control is created in the Settings folder (see under the Help
menu -> Open Settings Folder), called WebViewCache.
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Editing webpage notes

Note: This topic applies to the old webpage editor, i.e. when not using the Chromium based

https://developer.microsoft.com/en-us/microsoft-edge/webview2/consumer/
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viewer.

The webpage note allows you to apply basic formatting to the note contents (usually from a
webpage).

There are 2 levels of formatting available:

1) Font text and background color formatting, available from the color palettes (as in the
RichView and RichEdit note types). The note does not need to be in "Edit Mode" to apply
these types of formatting. This allows you to conveniently apply color highlighting to
desired text, without having to go into Edit Mode.

2) Other types of formatting such as font type (name), size, bold, italics, paragraph layout
etc.. require the note to be in Edit Mode. First press the "Toggle Edit Mode" button (also
available from the main menu Edit item), then the other formatting buttons become
enabled and can be used.

When the note is in edit mode you can also type in text and delete content from the note.

Some important notes on using the editor:

· When you go into edit mode, the layout of a webpage may change more or less
depending on the complexity of the webpage.

· When in edit mode, to edit text or apply formatting changes, you may need to first
select a region on the webpage, and then click in it again to get the text/edit cursor.

· NB: Sometimes if you use the DEL key to delete content from a webpage it will not
generate an edit event (i.e. the program will not notice that an edit occurred - and
therefore the "Save" button will not become enabled). In order to overcome this, you
need to make some small other edit on the page aswell (e.g. press space then
backspace..).

· The Edit toolbar is located on the bottom dock of the editor and is not visible by default.
You can make it visible with F10 (See View->Toolbar modifiers), and also move it to the
top dock if desired using Drag and Drop. See the Toolbars topic for more info.

Created with the Standard Edition of HelpNDoc: Full-featured multi-format Help generator

Outline note type

The outline note type is simply a standard RightNote tree within a note. It works exactly the
same as a normal tree, and you can set it's properties by clicking on the "Tree Properties"
icon of the inner tree:
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To help avoid confusion, the properties dialog title bar says: "Tree Properties [for current
outline]". The hotkeys will work for the tree that has current focus. If the outer (main) tree
has focus, then the hotkeys will work for that tree. Likewise, when the inner tree has focus,
the hotkeys will work for that tree.

Similar to above, when editing tags for a note in the inner tree, the dialog title will say
"Tags [for outline note]".

When you drag and drop notes from one tree to another, RightNote tries to do what is most
intuitive. For example, if you drag notes from an inner tree, to an outline note in the main
tree, RightNote will move the notes into the second outline, instead of placing them in the
main tree. In some cases RightNote will prompt "Do you want to move the notes into the
outline?" for clarification.

You cannot drag 'n drop notes from one outline to another outline on another page.
However, you can achieve the same, by cutting the notes (Tree->Transfer->Cut) from the
outline and then pasting them into the destination outline. (When pasting with
Ctrl+Shift+V, make sure you click in the destination outline so that it has focus, otherwise
the notes will be pasted into the main tree of the second page).

Task list

The task list note type is essentially an outline note type, except that it has checkboxes
visible. A handy feature of the task list note type is that the number of uncompleted tasks
(i.e. unchecked tasks) is indicated in the main tree.

Outline note options

A number of options are available for the outline note type and can be found in the Options
dialog under "Editors->Outline".

Printing and exporting an outline

Please refer to the Printing or exporting an outline topic for more details.

Created with the Standard Edition of HelpNDoc: Free Kindle producer

Converting note types

To convert from one note type to another, click on "Note Properties" (F2), and then click on
the Contents box. This will bring up a dialog that allows you to choose what note to convert
to.

https://www.helpndoc.com/feature-tour/create-ebooks-for-amazon-kindle
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Note: 
You cannot always convert from one note type to another. Usually you can convert between
text note types (i.e. Rich edit, Rich view, Memo, Source code..), however for example you
cannot convert a Richview note to an attachment or link note type. However, you can
convert an attachment note type to a link note type and vice versa.

Created with the Standard Edition of HelpNDoc: Benefits of a Help Authoring Tool

Marking a note as a folder

When you mark a note as a folder (from the right-click popup menu), then that note will
be shown in the Folders side panel. The folder property together with the folders panel
allow you to create a higher level of organisation for your notes and also easily navigate
large trees.
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RightNote

38 / 114

What is really special about folder notes is that all child notes (and the note itself) get
tagged with the note's caption - automatically. This means that as you add more structure
to your tree with folders, you will automatically be adding useful tag information to your
notes at the same time.

See Folder tags and normal tags for more information.

Created with the Standard Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation

Protecting your notes

Created with the Standard Edition of HelpNDoc: Full-featured multi-format Help generator

Introduction

RightNote includes an industry standard 128-bit encryption system that allows you to keep
your sensitive information confidential and secure. You can protect individual notes and
pages or an entire RightNote file.

All encryption and decryption is password based: this means RightNote does not store the
password in any "hidden" place or in some encrypted form. Instead, protected information
can only be retrieved after the password key has been supplied by the user. Without this
key no encrypted information can be decrypted.

https://www.helpndoc.com/help-authoring-tool
https://www.helpndoc.com/help-authoring-tool


RightNote

39 / 114

The following topics discuss RightNote's protection mechanism in more detail.

Created with the Standard Edition of HelpNDoc: Create cross-platform Qt Help files

File and note passwords

Many protection schemes are "file" based. This means that the user sets up a password for
opening the file, after which the file can only be opened with this password. Once the
password has been supplied all data is freely accessable until the file is subsequently closed.

For a note taking application this approach has it's drawbacks. Typically one likes to have
the application running (with an open file) in the background, so that one can easily restore
the application to insert new information or perform a search. If one uses a protected file in
this way, then it means that one's sensitive information will have to be left unlocked for
long periods, possibly compromising secutiry.

A "note" based scheme is one that allows you to place a lock on selected notes within a
notebook. This approach is more generally more secure, and avoids the problem mentioned
above, i.e. you can safely leave your file open and still keep selected notes secure. A
possible drawback with this approach is that accessing information may become more
inconvenient, having to unlock secure notes each time one bumps into them - compared to
the "file" based scheme where all information is readily accessable.

RightNote allows you to use both approaches:
· You can set up a "file" password to protect the entire file, and/or
· a "note" password which can be used to protect selected notes or pages.

These passwords are setup in the Protection tab of the File Properties Dialog. (File- >File
Properties).

After you have set up a "note" password, you can set the "Protect" property of a page (F6)
or a note (F2) in order to protect them.

Note: If you use a "file" lock, all notes will automatically be encrypted at the database level
(i.e. at the file level). However, to prevent access to specific notes once the file has been
opened (i.e. during program execution), a "note" password must be setup, and the specific
notes/pages must be set to protected (i.e. Protect = Yes).

NB: See note about "file" passwords in next topic.

Created with the Standard Edition of HelpNDoc: Produce Kindle eBooks easily

Features and usage

Central Locking

The "note" password works in a "central locking" type of fashion. Once you supply the
"note" password, for any reason: e.g. to unlock a note or during a search, the "note"
password is then available, and all protected notes are accessible. Likewise, once you "lock
the notes" (ctrl+L), all notes are locked.

Protected notes and the Full Text Search engine

A very useful feature of RightNote is the "Full Text Search" capability which allows you to
obtain search results very quickly. To achieve this, the database file needs to store a plain
text copy all note content which is then indexed in order to obtain fast searches. Obviously,
you don't want to keep a plain text copy of a protected note lying around somewhere in the
search index of the database.

https://www.helpndoc.com/feature-tour/create-help-files-for-the-qt-help-framework
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So keep this in mind: Any protected note cannot be searched with the Full Text Search (i.e
"fast" search) capability. It can only be searched via normal or database search. If you are
using "fast" search mode, and you have checked the "include protected" option, then
unprotected notes will be search via fast search and any protected notes will be search via
"database" search (provided of course, you provide the password or the password is
available).

Note: For this reason it is highly recommended that you generally do not use a "file"
password, as it will effectively disable the full text search function. Only use a "file"
password in specific cases and where appropriate for your needs.

Created with the Standard Edition of HelpNDoc: Free HTML Help documentation generator

Choosing strong passwords

Although the underlying encryption mechanism in RightNote uses a 128-bit cryptographic
"key" (which is very secure), this key is directly "derived" from the password supplied by
the user, and as the saying goes "a chain is only as strong as it's weakest link!", so if the
user's password has an effective strength of 64-bits (weak), it doesn't really help that the
encryption key is 128-bit. If someone uses their name as their password (or phone number
or pet's name..), it doesn't really help that the encryption key is 128-bit strong...this
password can easily be guessed and discovered.

Wikipedia has an excellent article on password strength which describes what makes a
password strong and the importance of choosing strong passwords. It is highly
recommended that you read this article in full to understand this topic in more detail.
http://en.wikipedia.org/wiki/Password_strength

As a short summary, here is a quote from the paragraph titled "Guidelines for strong
passwords".

"Common guidelines for choosing good passwords are designed to make passwords less
easily discovered by intelligent guessing:

· Include numbers, symbols, upper and lowercase letters in passwords
· Password length should be around 12 to 14 characters
· Avoid passwords based on repetition, dictionary words, letter or number sequences,

usernames, or biographical information like names or dates."

Remember:
The more random a password "looks" (numbers, symbols, upper and lowercase letters)
consisting of the more likely it is to be strong.

A technique mentioned in this article that you may find useful:
"Mnemonic passwords: Some users develop mnemonic phrases that generate seemingly
random passwords". Such passwords are easy to remember although they still appear to be
random.

Another quote from the paragraph titled "Examples that follow guidelines"

"The passwords below are examples that follow guidelines for a strong password. Since
these passwords have been publicly published, they should never be used verbatim.

4pRte!ai@3 — mixes uppercase, lowercase, numbers, and punctuation
Tp4tci2s4U2g! — built from a phrase that a user can memorize: "The password for (4) this
computer is too (2) strong for you to (4U2) guess!" — mixes types of character as well

https://www.helpndoc.com
http://en.wikipedia.org/wiki/Password_strength
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BBslwys90! — loosely based on a phrase that a user can memorize: "Big Brother is always
right (right angle = 90°)!" — mixes types of character as well. "

Created with the Standard Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation

Important information: Warnings and Precautions

Some important considerations to keep in mind when working with encrypted
notes/files:

RightNote does not store any Note or File Passwords within a file. If you forget a password,
then there is no way to retrieve any information that has been encrypted with it.

There are 2 factors you need to bear in mind when protecting notes:

v When notes (or content, if FTS is enabled) are deleted from a notebook, they aren't
completely deleted from the underlying database. It's more like their space is marked
"available for use", and will be used up at some point in the future when new data is
added to the database. What this means (in terms of security) is that you can't assume
if you just delete an unprotected note from a notebook that it's content no longer
exists. It may be lying somewhere in plain text in the database file. This problem can
be solved by compacting the database (File properties->Compression->Compact).
This action will completely delete any unused space in the database.

v Another issue to bear in mind - when you have the Full Text Search feature enabled, is
that parts of unprotected note content are stored within the full text index. Even if you
subsequently protect a note, some bits of this information will still be available
somewhere within this full text index. In order to remove this problem you would need
to completely delete and then re-create the Full Text Index.

The "File Cleanup" action (File->File Cleanup) performs the above 2 actions in one easy
step: It compacts the database, and re-creates the Full Text Index, thereby solving the
above mentioned security issues. As a convenience, the "File Cleanup" action is also
available from the Tree menu (Tree->Protection->File Cleanup), even though this action
does not relate specifically to the tree or page, but instead to the entire file.

Note: The above problems are only relevant to data that was initially unprotected and only
afterwards was protected. These issues do not apply to any data that is added to a
protected note/page/file.

Tip: In-order to avoid having to frequently perform a File Cleanup (which may take a
while for larger files), it's a good idea to set up beforehand a few protected notes or
protected pages, instead of adding data to unprotected notes and then later protecting
them - since in the latter case a File Cleanup is needed to establish proper security.

Created with the Standard Edition of HelpNDoc: Free EPub producer

Richview editor

Created with the Standard Edition of HelpNDoc: Easily create Help documents

Find bar

To search within a Richview note, press CTRL+F to bring up the Find bar. Type in the search
box the term you want to find. Press ENTER to start a search. Press ENTER again to find the
next search hit.

https://www.helpndoc.com/help-authoring-tool
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The search will start from the current cursor position. To start from the beginning, press the
Restart button (rounded arrow). When the search reaches the end of the document, the
Restart button will flash. If you press ENTER twice at that point, the search will restart.

Hide the Find bar by pressing ESC.

Created with the Standard Edition of HelpNDoc: Full-featured EPub generator

Hyperlinks

(This topic refers to hyperlinks within a RichView note)

Launching hyperlinks

· The default way to launch a link is with "ctrl+click".
· Additionally you can launch a link by double clicking on it, after you have checked this

option in the "Options dialog" on the Editors->RichView page.

Adding and editing hyperlinks

The hyperlink dialog allows you to easily create links to external documents, folders or
other notes within the same notebook. The buttons on the bottom-left corner allow you to
select a file, folder, or note respectively. (The fourth button allows you to change the colors
of the link).

The URL (link address) for internal notes starts with "rnt://".

If the link points to a note, then the "Note" edit box will show which note is being referred
to. If the target note no longer exists, then the edit box will show "Not found".

To change a hyperlink to normal text clear the target field.

Created with the Standard Edition of HelpNDoc: Free EPub producer

Spell check

Introduction

RightNote uses the hunspell (http://hunspell.sourceforge.net/) spell checking engine to
perform spell checking for RichView note types. The hunspell engine is used in well known
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programs such as OpenOffice, FireFox and Thunderbird, and provides dictionaries for over
90 languages.

The RightNote installation includes a English (U.S.) dictionary. Other dictionaries can be
downloaded from http://extensions.openoffice.org/. 

Dictionaries are distributed as an ".oxt" file. This is simply a zip file with a different name.
You need to first change the name to ".zip", and then extract the files. The ".dic" and ".aff"
files need to be placed in the RightNote "dictionaries" subfolder which is located next to
the settings folder. (See under the Help menu -> Open Settings Folder).

Here are the direct links to the:

English dictionaries (US, UK, GB, CA, AU, ZA)
English dictionaries pack @ extensions.openoffice.org

Russian dictionary:
Russian dictionary @ extensions.openoffice.org

And Greek dictionary:
Greek dictionary @ extensions.openoffice.org

Ordinarily you will only want to have 1 dictionary active at a time, however, hunspell (and
RightNote) gives you the option of loading more than one dictionary at a time. This is
probably for cases where a specific language may include some auxillary dictionaries.

Usage

If you only work with one language then all you need to do is setup the application wide
dictionary once. (This is set by default to English U.S.). However, in case you need to work
with different languages in a single file, you can setup file specific or even note specific
dictionaries. Open the "Select Dictionaries" dialog from the "Spelling->Select Dictionaries"
menu item of a RichView note.

RightNote sets up the current dictionary(ies)  in the following way:

· use dictionary setting of current note. If no dictionary is specified then
· use notebook wide dictionary setting. If no notebook dictionary is specified then
· use the globally defined dictionary(ies).

As you can see in the example above, you can define note specific dictionaries without
setting up any dictionary for the current notebook.

Dictionary Aliases

http://extensions.openoffice.org/
http://extensions.openoffice.org/en/project/english-dictionaries-apache-openoffice
http://extensions.openoffice.org/en/project/slovari-dlya-russkogo-yazyka-dictionaries-russian
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Downloaded dictionaries files are named with somewhat cryptic abbreviated names, so e.g.
the English U.S files are named "en_US", and English U.K. "en_GB". This may be a little
difficult to work with. You can define a dictionary alias in the "Dictionary Aliases" Dialog,
(Tools->Dictionary Aliases), and then this text will appear in the "Select Dictionaries" dialog
(as it does above).

Type in a dictionary alias in the right column.

Adding words to a dictionary

New words are saved to a separate file with the following name [dictionary]_new.txt, so for
example, new entries for the "en_US" dictionary will be saved to a file named
"en_US_new.txt". A current limitation with the RightNote integration is that these words
will not be included in spelling suggestions.
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Format code snippet

The "Format Code Snippet" action (under the Format menu), allows you to apply code
syntax highlighting to selected text (in a Richview note).

Part of the process involves setting up a list of frequently used code highlighters, so that
the highligher can be applied with a minimum number of clicks.

The process is as follows:

1. Click on the "Format Code Snippet" action (under the Format menu), or simply press
Ctrl+Shift+S (default keyboard shortcut).

2. You will then be presented with a list of frequently used highlighters. Use the up and
down arrow keys to select the desired highlighter. Then press Enter to apply. If the desired
highlighter is not in the list, or for more options click on the "More" button at the bottom.

3. If you pressed on the More button in the previous step, you will now be able to select
from the full list of available highlighters in the "Highlighters" drop down at the top of the
presented dialog. At this point, you can also select the desired colors theme (in the top
left), or font size/name (bottom left).

At the top of the dialog, you will see a "Frequent" button. Click on that to setup your list of
frequently used highlighters.

Created with the Standard Edition of HelpNDoc: What is a Help Authoring tool?
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Zoom function

The Richview note type has a zoom function which can be adjusted with the trackbar found
in the bottom right corner of the application Window - on the Status bar.

You will notice a drop down button next to the trackbar, from which you can select a specific
zoom setting. Actually the drop down and trackbar work together in the following way:
When you click on a zoom preset in the drop down list, the upper and lower bounds of the
trackbar will update relative to the selected value. This is an unusual behaviour, however it
allows you to more easily fine tune the desired zoom level.

If you don't care much for changing the zoom level and would prefer to hide the trackbar
altogether, this can be done via the setting under View->Bars & Panels->Zoom Indicator.

(Note for users of previous versions:

If you have been using an earlier version of RightNote (specifically before v5.5.x), you will
notice that the sizing of some elements is different in the newer version. For example, in
the earlier version images were never scaled depending on your DPI setting, although text
was. So images were always shown at 100% scaling. In the newer version, images as well
as text are scaled according to the OS (Operating System) DPI setting.

If for some reason you would prefer using the previous scaling there is an option available
in the Richview settings (Tools->Options->Editors->RichView) - "Use previous version dpi
scaling". Although using this setting is not recommended, especially if you are using a high
scaling setting (e.g. more than 150%) or multiple monitors with different DPI's.) 
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Insert bookmarks

The Insert Bookmarks dialog (available under the Insert menu) allows you to insert a
number of bookmarks into the current note, or into the note tree.

You enter a list of links in the memo area, and then RightNote will download the
information for each link and insert it as a bookmark into the current note or tree. While
the links can be any normal website links, the dialog has been designed specifically with
Youtube links in mind. Meaning, if you enter a Youtube link, RightNote will download the
Youtube thumbnail as well as related Youtube video information, such as publish date,
views, likes and duration, and then add that as a bookmark into the current note or tree.

The dialog can also be used in the following way. When you do a google search, you will be
presented with a list of links and information about each link. These links are generally
difficult to copy as is. Nevertheless, if you select and copy the information you are
interested in, and then paste it into the Insert Bookmarks dialog, RightNote will extract the
link information, so that the Google results can then be saved as a neat list of bookmarks in
RightNote.

So for example, if we do a search for "vuetify tutorial" (Hey... you may not be interested in
this ��), select the results that we are interested in, then copy and paste that into the
Insert Bookmarks dialog, then press "Go", RightNote will download the Youtube info for
each link, and then insert a bookmark for each one.

https://www.helpndoc.com/feature-tour/iphone-website-generation
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A couple of other points to be aware of:
· RightNote will skip any duplicate links, so no need to worry about adding the same link

twice.
· RightNote will skip any text above/below the link, i.e. it will only grab the links in the

dialog, and skip over any text.
· The "Include Youtube description" option, only applies when the "Insert into tree"

option is active.

Note: This feature is only available in the Pro version.
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Paste bookmarks

The Paste bookmarks action (under the Insert menu) is similar to Insert Bookmarks. While
Insert bookmarks provides a dialog with some options, Paste bookmarks stream-lines the
process, where you simply press a keyboard shortcut to insert a list of bookmarks into a
note.

Usage:
· First copy a url (webpage address) or a list of urls to the clipboard
· In a richview note, press the Paste bookmarks hotkey - Ctrl+Shift+B by default

RightNote will then download the information for each url, and insert a bookmark for each
one. While this action can be used with any url, it has been specifically designed for
Youtube videos, where it will download the video thumbnail and stats and then insert that

https://www.helpndoc.com/create-epub-ebooks
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as a RightNote bookmark.

When using the paste action, you don't have the option to insert the bookmarks into the
tree - they are inserted into the current note.

Note: This feature is only available in the Pro version.
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Insert Youtube transcript

The Insert Video Transcript action (available under Insert->Youtube), allows you to insert a
Youtube video transcript, into a Richview note. (Note: Transcripts are also called "Closed
Captions" or "Subtitles")

In the top edit box you enter the Youtube video id (this is 11 characters long, and usually
found after the  watch?v= part of the url), or simply enter the entire link to the Youtube
video.

If you enable "Insert as a table", then the transcript will be inserted as a table with 3
columns: a timestamp, the text for that timestamp, and then a blank column intended for
your own notes or comments. If not selected, then the  transcript will be inserted in a more
free-form way, with each timestamp/text pair added on a new line.

If you enable the "Split every..." option, then the transcript will be split into multiple parts,
each part being inserted into a new note in the tree. The number indicates a period of
minutes.

For videos with only a single transcript, then you just need to click on the Go button. If a
video has multiple transcripts, then you will need to first click on the Go button, and then
when available, select the desired language and then press the Go button again (now
saying "Continue"). You can also just double click the language, to continue with the
download.

Note: This feature is only available in the Pro version.
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Right to Left text

The Richview note type supports Right to Left text for languages such as Arabic or
Hebrew. There are actions available to control the direction of text for a selection of text,
entire paragraph or entire note. These can be found under the Paragraph > Text
Direction menu item.

There is also a toolbar available for easy access to these actions. This can be made visible
via the Paragraph > Text Direction > Toggle Right to Left Toolbar action (or under
the View->Toolbars dialog). By default, the toolbar is located on the bottom note area dock,
which can be made visible by F10 (View->Toolbar modifiers->Show/Hide Bottom Toolbar).

The default note direction can be set in the Richview options section of the Options dialog
(Tools->Options->Editors->Richview->Default Text Direction).

https://www.helpndoc.com
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Created with the Standard Edition of HelpNDoc: Free Kindle producer

Warning when loading note content

In some rare cases, an error or warning can occur when loading the content of a Richview
note, for example the note contains an unrecognised image format. If this happens, a small
panel will be displayed at the bottom of the note giving details of the error.

If the panel is red, this indicates an error, so you should then:
· Export the note as .rvf, and then

· Contact support about the issue, including the exported note as an attachment.

If you make any changes to the note and then press "Save", it is likely that the problem will
be resolved, however the problem content will be deleted.

If the panel is light yellow, this indicates a warning which may be inconsequential, for
example a conversion of ANSI to Unicode text occurred. In this case it may be safe to
continue using the note normally, although you could contact support just to make sure...

Created with the Standard Edition of HelpNDoc: Free EBook and documentation generator

Assorted topics

Created with the Standard Edition of HelpNDoc: Free help authoring environment

Running multiple instances

RightNote allows you to run multiple instances of the application at the same time. This way
you can keep more than one notebook open at a time.

You can also prevent a second instance from running by disabling the "allow multiple
instances" option in the "Startup" page of the Options Dialog. If you only allow one instance
to be opened at a time, then when you try to launch a second file from Windows Explorer
this file will be opened in the existing instance.

Warning

Care should be taken not to open the same file in two different instances. If you do this, in
some cases you will no longer be able to save the changes you make.

For example: You open the same file in two different instances of the application. In the
first instance you delete some notes, and then save. In the second instance, you make
some changes to one of the notes you already deleted in the other instance. Now you try
to save your work. You will encounter an error since the note you are trying to change no
longer exists!

In fact when you return to the second instance you will get a message "File has been
changed by another process. It is highly recommended that you reload the current file
now". To avoid any problems you should accept to reload the current file. This will update
the current view to the currently saved file.

Created with the Standard Edition of HelpNDoc: Qt Help documentation made easy

Go to page dialog

The "Go to Page" action/dialog (Page->Go to Page) allows one to quickly move to a desired

https://www.helpndoc.com/feature-tour/create-ebooks-for-amazon-kindle
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page/tab in the current notebook or any other notebook listed in the Favorite Notebooks
manager (File->Favorite Files).

Showing pages from only the current notebook or all Favorite Files can be toggled via the
toggle switch (top right corner). The list of pages can also be filtered via the edit box (top
left corner).

To open i.e. move to a given page, double click on it.

Keyboard access:
Open the "Go to Page" dialog with Ctrl+Q (The Q looks like a search/find icon). As you type
in the search box, the list will be filtered. When the focus is in the search box, you can
press ENTER. This will move the focus to the pages list view. You can then use the arrows to
move to the desired page. Then press ENTER to open that page.

Created with the Standard Edition of HelpNDoc: Write eBooks for the Kindle

Virtual notes

A virtual note means that the contents of this note are not stored in the database file, but
instead in an external file, the location of which is set in the "URL" field of the note
properties.

Working with virtual notes allows you to centralise your work with a number of files that
may be scattered in different locations on your computer.

You can turn "virtual mode" on for an existing note by changing it's "virtual" property (Note
properties Dialog) to "Yes - Edit" and supplying a valid URL (i.e. destination file to store this
note). Likewise you can turn virtual mode off by changing this setting to "No".

If the note you want to make virtual and the file you want to attach it to, both already
contain information then you will be prompted as to which information you want to
overwrite.

Created with the Standard Edition of HelpNDoc: Generate Kindle eBooks with ease

External links

It is possible to obtain a link to a RightNote note or paragraph (in a Richview note), that
can be used by other applications. When triggered in the external application, this will
result in RightNote starting (if it was not already started...), opening the specified notebook
and then moving to the specified note.

A sample link looks like this:
rnt://C:/Users/User/Documents/My%20RightNote/Notes/MyNotes.rnt?u=381&g=abcd8d92-
1b7f-444b-ac28-7ebbfc8c8f26

For example if you copy/paste such a link into the Address bar in Windows Explorer (and
press ENTER),  RightNote will be started and move to the specified note.

How to obtain a link to a note

In the Tree popup menu, under "Clipboard" click on "Copy Link to Note". The external link
for this note (as shown above) will be copied to the clipboard. 

How to obtain a link to a specific paragraph

Move the cursor to the paragraph you want to link to. In the popup menu (i.e. right-click

https://www.helpndoc.com/feature-tour/create-ebooks-for-amazon-kindle
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menu) click on "Copy link to this Paragraph".

How to link to a note or paragraph within RightNote

Within a Richview note, you can create a link to another note by pressing Shift+Ctrl+K
(Shortcut key for Quick internal link), and then locating the desired target note.

If you want to link to a specific paragraph, first get the link to this paragraph as described
above (i.e. right-click and click on "Copy link to this Paragraph"). Then press Ctrl+K
(shortcut key for Hyperlink). Paste the link into the Target field. Enter your description in
the Text field. You can also use this method to create a link to another note (i.e. instead of
using the "Quick Internal Link" dialog).

Note 1:
When an Evernote note type has been created in RightNote (i.e. it has never been synced
with Evernote), it's unique link will change after syncing with the Evernote service. So you
should first perform a sync and then Copy the link to this note. The application will warn
you if this is the case.

Note 2:
If you paste this link into the Hyperlink dialog (target field), and the link is from the same
notebook, then the notebook value will automatically be removed. This helps to keep the
link portable.

Created with the Standard Edition of HelpNDoc: Free help authoring tool

Webpage Capture

Details about how to capture a webpage are described in the Webpage note type topic.

Created with the Standard Edition of HelpNDoc: Easily create Help documents

SingleFile integration

SingleFile is a highly popular browser extension, that can save a copy of a webpage to your
local disk with high fidelity, and as the name implies - all in a single file. 

Although you can capture webpages with RightNote itself (using the webpage capture
hotkey, see Tools->Options->Global hotkeys), using SingleFile offers the following
advantages:

· SingleFile can capture pages that are behind a login dialog
· SingleFile is specialized for webpage capture, and as mentioned above, usually has very

high fidelity (i.e. captured webpages look like the original)
· All webpage content is saved to a single file
· Only needed content is included in the saved file. This often results in a overall smaller

file size

To enable the SingleFile integration, follow the following steps:

· Install the SingleFile browser extension for your browser of choice. (SingleFile works
with most popular browsers, including Chrome, Firefox, Microsoft Edge, Vivaldi, Brave,
Waterfox, Yandex browser, and Opera)

· Take note of where SingleFile saves its files to. (The default is C:
\Users\<User>\Downloads. You may want to save a page first to see where this folder
is. It can also be adjusted in the SingleFile settings)

https://www.helpndoc.com/help-authoring-tool
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· Now in RightNote, enable the SingleFile integration. This is found in the Options dialog
(Tools->Options), under Main->SingleFile integration, check the checkbox next to
"Enable SingleFile integration".

· Make sure the Download folder is set to the correct folder

So now, if you press the SingleFile download button in your browser, after the download
completes, RightNote will come up with the clipper dialog to prompt you where the file
should be saved. The downloaded file will then be stored in the RightNote database itself, so
the original file could then be deleted from the local disk. Note in the options, you can
indicate whether the downloaded file should be deleted, or moved into a different folder
(e.g. C:\Users\<User>\Downloads\Done), or in fact, just left alone.

Note #1: The SingleFile integration is a feature of the Pro version.

Note #2: In some cases it will appear that SingleFile has not captured an image. This is
most likely due to the current limitation of RightNote's in-built browser engine, which is
based on Internet Explorer, and does not display some modern image formats, however the
image has in fact been captured. We do have plans to upgrade the browser to a more
modern engine (based on Chrome) which will be able to display these more modern images.

Created with the Standard Edition of HelpNDoc: Free Qt Help documentation generator

Working with Icons

Downloading and installing the complete icon set

The default installation comes with a minimal set of icons in order to minimize the download
size of the main installation package and future updates.

There is however a much larger icon set available for download at our site at the following
address: www.bauerapps.com/SystemIcons.db3 .

This file should be downloaded and then placed in the RightNote "Icons" folder overwriting
the existing SystemIcons.db3 file:

On Windows XP this folder is located at:
C:\Documents and Settings\USER NAME\Application Data\RightNote\Icons

On Windows Vista this folder is located at:
C:\Users\USER NAME\AppData\Roaming\RightNote\Icons

For portable installations, the "Icons" folder is a subfolder of the main RightNote folder.

Subsequent installations of RightNote will not delete this file.

Custom icons

You can also add your own custom icons to the application with the Icon Manager. Custom
icons are stored in a separate database file named CustomIcons.db3.

More information about how to add custom icons and how to customize the icon palette can
be found under the Icon Manager topic.

Created with the Standard Edition of HelpNDoc: Produce online help for Qt applications
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Reminders

RightNote now includes a simple reminder feature that is compatible with Evernote's
reminder system. If you use the Evernote sync feature, your reminders will be synced as
well. (Note that you can use the reminder feature in RightNote even if you do not use
Evernote's sync feature at all.)

You can assign a reminder to a note from the tree's right-click menu. In the dialog that
follows, you can select a simple reminder, i.e. one that includes no specific date, or you can
select a specific date for the reminder. You can also include a small note with the reminder.

To view all reminders in a file, open the Reminders dialog from under the Tools menu.
You can also view all reminders from across recently used files, favorites and Evernote files,
by selecting the "All notebooks" option.

You can see that the reminders are colour coded as follows:

Some time in the future White background

Soon (within 7 days) Light yellow background

Overdue (in the past) Red background

Done Grey background

Simple reminder (no reminder Light blue background
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date)

The list can easily be filtered according to the shown categories: Soon, Future, Overdue,
Done and No date - just click on the corresponding button to filter the list.

If you double click on a reminder in the list, it will move to that note in the notebook, or if
it is from a different notebook, it will open the note.

Notes:
· The reminder note is not synced with Evernote. It is only stored within RightNote.

· The reminder feature is intended to be a simple way to associate some reminder/due
date with a given note. It is not intended to be a full fledged to-do manager.

Created with the Standard Edition of HelpNDoc: Free CHM Help documentation generator

Date format strings

Various parts of the application allow you to specify a "date format string" which determines
how a date, time or date-time value is displayed.

For example:
· In a spreadsheet note, each cell has a "format string" property. A "date format string"

can be specified here to control how a date value is displayed.
· In the general options, the date/time format settings allow you to specify a "date format

string" to be used when inserting a date or time value into a note.

Some simple date format string examples:
1.  The string "dd MMMM yyyy" will display the date as (for example) "1 January 2009".
2.  The time format string "hh:mm:ss AM/PM" will display the time as 06:21:28 PM.

Date format specifiers:

c        Displays the date using the format given by the ShortDateFormat global variable,
followed by the time using the format given by the LongTimeFormat global variable. The
time is not displayed if the date-time value indicates midnight precisely.

d        Displays the day as a number without a leading zero (1-31).

dd      Displays the day as a number with a leading zero (01-31).

ddd     Displays the day as an abbreviation (Sun-Sat).

dddd   Displays the day as a full name (Sunday-Saturday).

e        Displays the year in the current period/era as a number without a leading zero
(Japanese, Korean and Taiwanese locales only).

ee      Displays the year in the current period/era as a number with a leading zero
(Japanese, Korean and Taiwanese locales only).

g        Displays the period/era as an abbreviation (Japanese and Taiwanese locales only).

gg      Displays the period/era as a full name. (Japanese and Taiwanese locales only).

m       Displays the month as a number without a leading zero (1-12). If the m specifier
immediately follows an h or hh specifier, the minute rather than the month is displayed.

https://www.helpndoc.com
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mm     Displays the month as a number with a leading zero (01-12). If the mm specifier
immediately follows an h or hh specifier, the minute rather than the month is displayed.

mmm  Displays the month as an abbreviation (Jan-Dec).

mmmm Displays the month as a full name (January-December).

yy      Displays the year as a two-digit number (00-99).

yyyy   Displays the year as a four-digit number (0000-9999).

h        Displays the hour without a leading zero (0-23).

hh      Displays the hour with a leading zero (00-23).

n        Displays the minute without a leading zero (0-59).

nn      Displays the minute with a leading zero (00-59).

s        Displays the second without a leading zero (0-59).

ss       Displays the second with a leading zero (00-59).

z        Displays the millisecond without a leading zero (0-999).

zzz     Displays the millisecond with a leading zero (000-999).

t        Displays the time using the format given by the ShortTimeFormat global variable.

tt       Displays the time using the format given by the LongTimeFormat global variable.

am/pmUses the 12-hour clock for the preceding h or hh specifier, and displays 'am' for any
hour before noon, and 'pm' for any hour after noon. The am/pm specifier can use lower,
upper, or mixed case, and the result is displayed accordingly.

a/p Uses the 12-hour clock for the preceding h or hh specifier, and displays 'a' for any
hour before noon, and 'p' for any hour after noon. The a/p specifier can use lower, upper, or
mixed case, and the result is displayed accordingly.

ampm Uses the 12-hour clock for the preceding h or hh specifier.

Created with the Standard Edition of HelpNDoc: Easily create Web Help sites

File version updates

In some cases, a new release may need to upgrade your existing files to a newer file
version in-order for them to work properly with the latest application version. To be on the
safe side a backup of the previous file is made with the extension "bak" + old file version
number.

Created with the Standard Edition of HelpNDoc: Write EPub books for the iPad

Journal

The Journal feature allows you to view your notes in a chronological tree. Notes are
grouped together by year and month based on their creation date, and then arranged
chronologically. As you add new notes they will automatically be placed at the correct

https://www.helpndoc.com/feature-tour
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location in the tree. If a year/month node does not already exist, it will be added to
accomodate the current note.

When the tree is in Journal mode, we can speak of different levels. The year and month
level do not refer to specific notes as per usual. Instead if you click on a month node, you
will see a calendar display of all notes in that month. Currently, if you click on a year node,
you will just see a blank display.

The next level is the "Journal note level". On this level all notes are arranged
chronologically based on their creation date. Any notes below the Journal note level, will
operate as per a non-Journal tree, i.e. they will not arrange themselves chronologically. It
is only notes that are at the Journal note level, that are arranged chronologically.

How to enable Journal mode

You can set or unset Journal mode from the Tree Properties dialog (F4). If you set the
Journal property, only notes at the root level are going to be arranged chronologically. If
you have a tree with sub-notes, and you want all notes to be arranged chronologically, you
can use the Flatten Tree action (under the Tree menu: More...->Flatten Tree). This will
move all notes to the root level, so that they will then be arranged chronologically in
Journal mode. Note however, that the Flatten action cannot be undone!

Journal mode is fully integrated into the application. You can use any note type at the
Journal level, and you can enable Journal mode for any tree, including the Evernote Sync
Inbox tree.

Calendar View

As mentioned, if you click on a month node, you will see a Calendar view of all notes in that
month. Notes are arranged according to their creation date. You can move notes to a
different day, and their creation date property will be modified accordingly. Conversely, you
can change the creation date property of a note, and it will then move to the corresponding
day/location in the tree.

Created with the Standard Edition of HelpNDoc: Free Qt Help documentation generator
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Note thumbnails

You can assign a thumbnail image to each note, which will then show up in the tree. This
can be used to make a note more easily identifiable and also make it easier to remember
what's inside the note.

To assign a thumbnail, right-click in the tree and click on "Thumbnail". This will bring up a
dialog that allows you to paste in an image from the clipboard or to load an image from
file. 

The tree menu also has a sub-menu with "Load from Content" and "Load from Content (All)"
menu items. These actions will extract the first image from a Richview note. (They do not
work for other note types). As such, this action can work hand in hand with the Bookmark
feature, to easily add the bookmark thumbnail as the note thumbnail. The "Load from
Content" and "Clear Thumbnail" actions, will apply to all selected notes. The "Load from
Content (All)" action applies to all notes in the tree.

Note: This feature is only available in the Pro version.

Created with the Standard Edition of HelpNDoc: Free help authoring tool

Insert Youtube playlist

The "Insert Youtube Playlist" action is available for the Richview and Spreadsheet note
types, and can be accessed from the Insert menu. When executed, this action will download
the playlist information, and insert it as a table into the current note. Additionally the note
caption and url will automatically be set to the Playlist title and url.

Important: When inserting a playlist into a spreadsheet note, it will overwrite any existing
content, so make sure to use the action on a new note.

When you click on the action a dialog pops up, that allows you to enter the desired playlist
id (for example "PLillGF-RfqbYhQsN5WMXy6VsDMKGadrJ-") or full youtube link (i.e
https://www.youtube.com/playlist?list=PLillGF-RfqbYhQsN5WMXy6VsDMKGadrJ-). 

There are a few options available:

https://www.helpndoc.com/help-authoring-tool
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· If the current note is a Richview note, then you have the option to include a small
thumbnail image with each entry. This option is ignored if the current note is a
Spreadsheet note. (Hint: If you choose to include the thumbnail images and then decide
you don't want them, you can easily remove them using the "Remove all pictures"
action from the "Insert" menu).

· You can also insert the entries into the tree itself. In this case you have the option to
include a bookmark with each entry. (Note: If you do include a bookmark, it will be
slower adding the items to the tree. If the playlist has a large number of entries it could
take a while for all entries to be added to the tree.)

Note: This feature is only available in the Pro version.

Created with the Standard Edition of HelpNDoc: Easily create HTML Help documents

Horizontal separator in the tree

If you set a note caption to "-" (i.e. a dash), then it will be displayed as a horizontal line in
the tree. This can help to create different visual sections within the tree.

If at some point you want to change the note caption, you will notice that it is actually
difficult to put the node into edit mode. This is because the caption is very small and you
wont know exactly where to click to start an edit. The best thing to do in this case is to use
the keyboard:

· Click on a node above the horizontal line
· Press the down arrow to move onto the horizontal line node (It wont be visible that this

node is now selected)
· Press the space key to start an edit

Created with the Standard Edition of HelpNDoc: Full-featured Help generator

Split Tree view

The Split Tree feature makes it easy for you to re-organize large trees. When the tree is
split, you can for example, scroll down to the bottom of one tree, and to the top of the other
tree. Then simply drag and drop notes from the one tree. As you make changes to the one
tree, they will be reflected in the other tree.

The Split Tree function is available as a button in the Tree options toolbar, (which may be
hidden if the tree width is small), as well as under the "Actions" menu item in the right
click menu. Click on the button to split the tree, click on it again to close the split tree.

In the right click menu of the second tree (i.e. on the right side), under the View menu
item, you can control whether to show the Folder panel or not, as well as the note type in
the tree.

Note:
Most operations in the one tree, will cause the other tree to reload. For medium sized trees
there will be little delay as this occurs. As the tree grows larger, the delay will become more
noticable. In general, once a tree becomes very large, it is recommended to divide your
notes across multiple tabs/pages, for best performance.

Created with the Standard Edition of HelpNDoc: Free CHM Help documentation generator

Side Trees

The Side Tree function allows you to easily move or copy notes from one tree to another,
since both trees can be viewed side by side at the same time. The selected side tree can be
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from the same notebook or from a different one.

To select or show the side tree click on the Tree icon in the toolbar. (Toggle Side Tree is
also available from the tree right click menu under Actions). If no side trees have been
selected before, then you will be prompted to select a side tree. The dialog that pops up is
similar to the "Go to Page" dialog, which allows you to select a page from the current
notebook. You can also click on the "Select Notebook" button, to select a different notebook.

Once you have selected a tree, you can click on the Tree icon again, to hide the side tree
view. You will notice on the bottom of the side tree pane, there are two buttons. The button
with the left pointing arrow/bracket will close the side tree pane, whereas the button with
the X, will remove the side tree. Clicking on the bottom panel will allow you to change the
current tree, i.e. select a different tree. Additionally, if you right click on the bottom panel,
you will see a menu item that allows you to add a second side tree. This action is also
available in the tree right click menu under Actions.

Note: The application allows you to select a maximum of two side trees, which will give you
a total of three trees side by side (including the main tree).

To get an overview of which side trees have been selected for the current notebook, click on
the Side Trees Overview menu item, under the Tools menu.

Created with the Standard Edition of HelpNDoc: Free PDF documentation generator

Templates

The Template feature allows you to define certain notes as "Templates" which can then be
used when creating new notes.

How does it work?

In the "Note Properties" dialog (F2), in the bottom left of the dialog, click on the drop down
next to "Template" and select "Yes". This will mark the note as a template.

Now when creating a new note, in the tree right click menu, under "Add Sibling" or "Add
Child", click on the "Template" option. In the dialog that pops up afterwards, double click on
the note entry you want to use as the Template for the new note.

Hint: RightNote does not enforce you to create a template in any specific location in your
notebook. However, it is recommended that you place them under a heading "Templates",
or in a page titled "Templates", so that you can more easily locate them at a later point.

Note: You need to save the database, before the note will appear in the Template list.

Note 2: Templates are part of the Pro version.

Created with the Standard Edition of HelpNDoc: Generate Kindle eBooks with ease

Sending bug reports

When an error occurs while running the application, a dialog will popup which allows you to
send a bug report to support. Click on the "Send bug report" button, and proceed with the
steps that follow. 

https://www.helpndoc.com
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The program will then try to send the bug report in the background, and you will see
progress of this in a small popup in the bottom right of the screen. If this does not succeed,
the program will then attempt to create the bug report via your default installed email
program (e.g. Thunderbird), i.e. create a new email with the bugreport attached, and then
you need to send the email manually (i.e. click on the send button).

If there is no installed email program on your computer (e.g. you only use gmail), then the
bug report will be saved automatically to a folder on your computer. You can open this
folder from under Help->Debug->Open Bug Report Folder. In this case you can send the
bugreport.txt file to support manually (i.e. create an email, and attach the bugreport.txt file
to it). 

Note: If the "Open Bug Report Folder" action is disbaled, it means that no bugreport.txt file
exists.

Created with the Standard Edition of HelpNDoc: Generate EPub eBooks with ease

Search

Created with the Standard Edition of HelpNDoc: News and information about help authoring tools and
software

Global search

RightNote includes a powerful full text search (FTS) engine that allows you to find specific
search terms very quickly.

In order to use the FTS engine, this option must be enabled for a given notebook in the File
Properties dialog (which it is by default).

Using Fast search

The search box is found on the "Search" tab of the resource panel (F9), and can be
accessed quickly using the "Ctrl+G" shortcut.

As you type in your search query, results will be displayed in the search results tree below.
Some important settings that control how the search behaves:

From Options->Search settings:
Include sample text for FTS Text samples are always included in search results (not

recommended). If you have not included search results
then you can activate search results for the current search
by clicking on the "show/hide details" button (or use
shortcut-"Alt-D").

Include FTS samples if less
than ... results

Text samples will be shown when results are less than (or
equal to) the set value. (If zero then samples will never be
shown). This setting helps the search process work
smoothly: If your query is returning a large number of
results then text samples are not shown so you can get a
better overview of how many search results there are, and
provide a more specific search term to narrow down
results. Then when there are only a few results text
samples will be shown.

From Options pane on Search Tab:
Match whole word (for all Match whole or if unchecked only part of a word.

https://www.helpndoc.com/create-epub-ebooks
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search modes)

All terms (for FTS only) Match all terms together or if unchecked then match any
term.

Keystrokes/Shortcut summary:
Ctrl+G Start search / Focus search box

Enter Focus search results tree

Alt+D Show/hide details (i.e text samples)

Alt+E Expanded/collapse details

Fast search limitations:

· partial matches are only found at the beginning of a word, so for example "ver" will
match "version", but it will not match "converse". (This limitation does not apply to
normal or DB search).

· Fast search does not search for tags

Some additional notes:

· "including protected" notes will slow down FTS, since these notes are not included in the
text index and are searched using DB search.

· when using FTS the file becomes larger in order to store the full text index.
· FTS only works if the search term is larger than 2 characters. To search for a term

smaller than this you need to manually press the search button (or Alt-S).

For these reasons,  two other search modes are available although usually it's best to use
fast search.

Normal search mode

You may be suprised at how slow the search is the first time that you run it in normal
search mode. This is because RightNote only loads a note when it is needed. This accounts
for the quick file loading time when opening an existing RightNote file, even if it is a large
file containing many notes.

The down side to this is that when performing a search (in normal mode) all notes need to
be loaded, and so therefore the first search will take longer than subsequent searches. You
will notice that all subsequent searches are much quicker.

Database search mode

All notes are searched directly from the database. This search will always be as slow as the
first search of a normal search. The advantage however is that notes aren't stored in
memory (unlike normal search), so this method doesn't affect computer memory usage.

Created with the Standard Edition of HelpNDoc: Easily create iPhone documentation

Multi-Notebook Search

The multi-notebook search feature allows you to search through all your RightNote
notebooks almost instantly.

How does it work?

https://www.helpndoc.com/feature-tour/iphone-website-generation
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First go to the Search tab of the Resource Panel (F9 or Ctrl+G):

At first, the multi-notebook search button will be disabled. Click on it to enable multi-
notebook search:

Once enabled, as soon as you start typing in the search box (more than 2 characters...),
you will see search results appear at the bottom of the search panel, showing the names of
notebooks that contain search hits. To view details for a given notebook, click on it. You will
then see a bar at the top of the search results tree, indicating which notebook is currently
being searched for details:

If you don't see the bar, then it means results are being shown for the currently open
notebook. If you do see the yellow bar, it means results are being shown for a notebook
that is not currently open in RightNote. To stop viewing results for the particular notebook,
click on the red close button.

If you click on a search result (in the results tree) then a dialog will pop-up showing the
details of that particular note:
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You can even edit this note in-place and then save changes. If you want to open the
notebook click on the "Open NoteBook" button.

Once you no longer need to see the note details click on the "Close" button to close the
dialog.

That's pretty much it. See below for some extra details.

Note: You can do a multi-notebook search even if there is no file open at the time.
Note 2: This feature is only available in the Pro version

Multi-notebook search settings

One thing we haven't discussed so far is, how does RightNote know where to look for a list
of RightNote files to search in??

This is handled in the "Multi-notebook search settings dialog" (under Tools). Here you
can select which list of files to include in the "MNB" search. By default this includes all files
from your favorite files list. You can also include any number of other folders, and then all
RightNote files in these folders will be included in the MNB search.

Created with the Standard Edition of HelpNDoc: Free Qt Help documentation generator

Incremental Search

If the tree window has focus, and you are not editing a note caption, then simply typing in
the characters of a note in this tree, will take you to this note.

For example, you have a note called "Documentation" somewhere in the current tree. Just
start typing in the letters "doc..." and you'll be taken to this note.

Created with the Standard Edition of HelpNDoc: Full-featured EBook editor

Resource panel and toolbars

Created with the Standard Edition of HelpNDoc: Free iPhone documentation generator

Resource panel

The resource panel gives you access to some useful features for working with RightNote
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files:

· Global search - allows you to search all notes for a given text or tag

· Tag panel - powerful tag search functions. Shows tags for current page or entire
notebook.

· Note history - keeps track of recently accessed notes, allowing you to see a list of
which notes you have recently used, frequently use and have used in this program
session.

· Scratch pad - allows you to quickly jot down some notes not connected to any
particular file, and may be used to store information in a case where you don't have
enough time to decide where to put this information. You probably won't need to use
this feature often, and could just as well use a note for this purpose.

Created with the Standard Edition of HelpNDoc: Create help files for the Qt Help Framework

Toolbars

Show/Hide toolbars

The various toolbars in the application can be shown or hidden via the toolbar settings
dialog, (under View->Toolbars). Each "section" (or panel) has a list of the toolbars
contained in it. Place a check next to the toolbars you want visible.

Moving toolbars

Within each viewer (e.g. RichView editor pane, Spreadsheet editor pane, etc..) toolbars can
be moved around, and can also be moved from either the top dock to the bottom dock, or
vice versa. Each toolbar has a little handle at it's left most side:
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When you move the mouse over this handle, the cursor changes to a "move" cursor. Click
the left mouse button, drag the mouse to where you want to move the toolbar to, and then
release. The bottom dock exists at the bottom of the editor window, and will not be visible if
it contains no toolbars. When moving a toolbar from the top dock to the bottom dock by
dragging the mouse past the bottom of the editor, the toolbar will suddenly "jump" to the
bottom dock as the mouse moves over it.

Toolbar modifiers

There are a few toolbar settings available that override the default toolbar visibility,
available under the "View" menu item:

· Show bottom Toolbar
Toggles visibility of all toolbars in the current editor's bottom dock. (Each editor has it's
own setting).

· Show Toolbars
Toggles visibility of all toolbars in one go. Once pressed all toolbars will be hidden,
overriding any specific toolbar settings. When pressed again all toolbars that were
visible before (being hidden) will become visible.
Note: The main menu toolbar (and any other toolbars on the same row) is not hidden by
this action.

· Full Screen Mode
Toggles hiding all top toolbars (including the main menu bar), the status bar, and the
main application window border.

Created with the Standard Edition of HelpNDoc: Easily create HTML Help documents

Hiding notebook tabs

It is possible to hide the notebook tabs via the View->Show/Hide Tabs menu button.
(Default shortcut key is Ctrl+Alt+T). When the tabs are hidden, a panel will show up just
above the note tree displaying the notebook name (i.e. filename) and current page.
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If you click on the page title ("Javascript" in the image above), a popup will be displayed of
all notebook pages. You can then click on a page to "move" to that page. Likewise, if you
click on the notebook filename, your list of favorite files will be shown in a popup.

You may want to use this setting in combination with unchecking the View->Toolbar
modifiers->Show Toolbars option (Shift+F10), to achieve a really compact UI (user
interface) display, as shown in the image below:

Note: If you are new to RightNote, you may find it hard to understand what is happening if
you hide the tabs. This is something to try once you are familiar with the application and
will be able to visualize what is happening "behind the scenes" when the tabs are hidden.

Created with the Standard Edition of HelpNDoc: Generate EPub eBooks with ease

Tags

Created with the Standard Edition of HelpNDoc: Create help files for the Qt Help Framework

Concepts

Tags allow you to "label" a note with a given word or phrase. Tags can be used for a number
of different purposes, 2 of which are mentioned here:

1.  Grouping/Categorising - (Referred to as "category" tags). The hierarchical tree
structure naturally lends itself to organising information. One of the limitations of the
tree structure is that notes cannot simultaneously belong to different parents. Tags can
overcome this limitation by allowing you to group notes from different trees or branches
together by a category tag word. Your tree hierarchy may represent the primary or
main structure of how you would like to organise your information, and using tags you
can group together different elements of this structure in alternative ways. (Notes are
"grouped" by a tag, by the fact that when you search for a tag (on the tag page of the
resource panel), all notes with this tag will be shown).

2.  User information - (Referred to as "user" tags). Tags can also be used to highlight the
relevance of a particular note to you. For example "Important", "Urgent", "To do", etc.

Category tags describe the information in the note, whereas user tags highlight the
relevance of a particular note to the user.

RightNote allows you to associate an icon with a tag which is then displayed in the tree
view:

https://www.helpndoc.com/create-epub-ebooks
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The main purpose of associating an icon with a given tag is to highlight and remind the user
of the relevance this note has to him/her. It is therefore recommended to only assign icons
to "user" tags, and not to "category" tags.

Tag search

Tags also allow you to search for information in an alterative - more general way. If you
know exactly what you're looking for, then usually you can find this information very
quickly using RightNote's global search function (Search page of Resource Panel F9). If
however, you don't know exactly what you're looking for, but you know that it has to do
with e.g. "News" (tagged with "News") and "Forums" (it was a forum post, and tagged with
"Forum") and "Internet", then you can find the note(s) you are looking for using the tag
search.

Created with the Standard Edition of HelpNDoc: Benefits of a Help Authoring Tool

Assigning tags

Add tags to a note by opening the "Tags" dialog. This can be done by:

· clicking on the "tags" toolbar icon
· clicking on the "tags" item on the popup menu (opened with right-click) of the note tree

view.
· clicking on the "tags" button on the "Tag Panel" (found at the bottom of the note editor):

(Tag Panel - found below the note editor)

(Tags dialog)

To add a tag, start typing in the edit box. A list of existing tags that match the current text
in the edit box will be shown. To select one of these, use the up/down arrows and press
enter. To see the list of existing tags when the edit box is blank, press the down arrow.

If you press enter, and the tag does not yet exist, then it will automatically be added to the
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list of tags.

To delete a tag double click on the tag entry in the list box.

Note:
If you are editing tags for multiple notes you cannot delete or add any folder tags.

Created with the Standard Edition of HelpNDoc: Full-featured EBook editor

Folder tags and normal tags

Understanding how "folder" tags and "normal" tags work, may take a bit of time to "sink
in". However, once you understand the way they work, you will see that it flows quite
naturally.

When a note gets marked as a Folder (from the right-click menu), then the caption of that
note gets applied as an automatic tag to all child notes (and the note itself). If for example,
you change the caption of the note, then the child tags will be automatically updated.

If you bring up the note "Tags" dialog (Ctrl+Shift+T), you will see that automatic tags are
marked with a greyed out folder (In the image: Indy and Installation - 2).

You can add tags to a Folder note, just like normal notes (In the image: Idea - 1). By
default, these will not be applied to child notes. If you want a tag that you have added to a
Folder note to be applied automatically to child notes, then right click on it and click on
"Make as Folder Tag".

(If at some point you want to change the tag to only apply to the Folder note and not to the
child notes, then click on "Make as Normal Tag").

Note:
If you are editing tags for multiple notes you cannot delete or add any folder tags.

https://www.helpndoc.com/create-epub-ebooks
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Created with the Standard Edition of HelpNDoc: Easily create Qt Help files

Managing and searching for tags

The Tags panel found in the tree's left dock area, allows you to manage all your tags.

Most actions are self-explanatory. Clicking on a tag will bring up a third panel (in between
the tree and note editor) that shows all notes containing that tag, and also shows a list of
related tags. 
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Clicking on a related tag, will add that tag to the search, and show a list of notes containing
the first and second tag, as in the following picture:

You can see that in this case (when searching for notes containing the tags "How to" and
"Tags"), there are no further related tags. Clicking on one of the search tags (i.e. "How to"
or "Tags"), will remove that tag from the search, and update the search results.

Merging tags
You can merge one tag into another: After you click on "Merge Tag" you will be prompted to
select the "target" tag, i.e tag to which the currently selected tag should be merged to.

For example you have 2 existing tags: "Computer related" and "Computers". Now you
want to merge these 2 tags into 1 tag, e.g. merge "Computer related" into "Computers", so
that "Computer related" will be deleted, and all previous links to "Computer related" will be
converted to "Computers".
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For this example, to accomplish this: Select the "Computer related" tag. Then click "Merge
tag". Now select the desired "target" tag, in this case "Computers", then press OK. All
references to the "Computer related" tag will be converted to "Computers", and the
"Computer related" tag will be deleted.

Created with the Standard Edition of HelpNDoc: Free EPub producer

Tasks

Created with the Standard Edition of HelpNDoc: Write EPub books for the iPad

Tasklist setting

Any tree (or inner tree i.e. Outline/TaskList note type) can contain a mix of task and non-
task items, i.e. notes with checkboxes and notes without checkboxes. As a convenience
feature, whenever you create a new note, whether it has a checkbox or not will follow the
setting of it's previous sibling (i.e. the note above it but not its parent).

What happens when you create the first child to a note?

In the Tree Properties dialog, there is a setting "Task List" (Yes/No). What this means is that
when you create the first child of a note, if the tree is a Task List, then it will have a
checkbox, but if the tree is not a Task List, then the new note will not have a checkbox. In
other words, when marked as a Task List, a tree will prefer to create Tasks (i.e. notes with a
checkbox).

Created with the Standard Edition of HelpNDoc: Easy CHM and documentation editor

Project

Any note can be marked as a Project. When this is the case, a pie will appear next to the
note in the tree, indicating the percent of completed child tasks.

Mark a note as a project in the Task Properties dialog (available from the Tree right click
menu, under Tasks)

Created with the Standard Edition of HelpNDoc: Full-featured Kindle eBooks generator

Task features per RightNote version

This topic describes which Task related features are available per RightNote version:

Freeware
version

None

Standard
version

Checkboxes

Pro version Priority, Projects, Start and Due dates

Created with the Standard Edition of HelpNDoc: Benefits of a Help Authoring Tool

Options

Created with the Standard Edition of HelpNDoc: Full-featured Kindle eBooks generator

Settings location

RightNote includes a large number of options which allow you to customise and control how
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the user interface and program works. These options can bring the program to life, as they
allow you to customise the program to you own particular needs, desires and circumstances.

It's a good idea to page through the various items on the options tree to see what options
are available.

For the standard install version of RightNote, settings are stored:

For Windows XP to:
C:\Documents and Settings\USER NAME\Application Data\RightNote\Settings

For Windows Vista to:
C:\Users\USER NAME\AppData\Roaming\RightNote\Settings

For the portable version of RightNote, settings are stored in a "\Settings" subfolder,
relative to the main RightNote folder.

Hint:
To make things simple you can open the settings folder from:
Help->Installation Information->Open Settings Folder

Created with the Standard Edition of HelpNDoc: Free help authoring tool

Backup settings

Default backup location

The default backup location for the installed version of RightNote is: " My Documents\My
RightNote\Backup". For the portable version, backups are saved to a subfolder "\Backup"
relative to the location of the main application file (RightNote.exe).

The backup path supports two "variables": {mydocuments} and {app}.

The {mydocuments} variable is converted to the "My Documents" folder of the current
operating system. For example on a Windows XP system, this folder maps to "C:\Documents
and Settings\USER NAME\My Documents", where as on Vista and later it maps to "C:
\Users\USER NAME\Documents".

The {app} variable maps to the current location of the RightNote application file -
RightNote.exe.

You can insert these variables in your backup path, without having to specify their current
location - which may change for example if you move your RightNote portable installation
from one folder to another.

If the backup location is left blank then backups will be stored in the same folder as the
RightNote file.

Note: Backup files have the current date (and time) plus "_bak" appended to the original
filename. If you open and modify one of these backup files, RightNote will not create
backups of backups - i.e. it skips backing up files that end in "_bak". You therefore need to
rename the file and remove the "_bak" part of it, for normal backup to resume.

Backup settings

The "Backup file before saving" option controls whether RightNote creates and stores
backup copies of open notebooks or not. Backups are created after every save.

https://www.helpndoc.com/help-authoring-tool
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There are two possible timeframes that can be used:

Method 1:

If the "limit backups to one backup per day" option is checked, then all changes to the
current notebook will be saved into only one backup file per day - so the last backup file will
only contain the most recent changes of the current day. The next backup file (assuming
you have more than 1 backup files) will contain the last change made on the day before.

The advantage of this method is that each backup file is one day older than the next.
Because the timeframe between backups is larger than method 2 (see below), if something
should suddenly go wrong, then there is a greater chance that your older backups will still
be "ok".

Method 2:

If the "limit backups to one backup per day" option is not checked, then a new backup
file is created after every save (and old backups will be deleted as per your backup number
limit). So with this method old data is quickly replaced by new data.

Method 2 makes more sense if for example you are maintaining a number of old backups
with some other backup tool or method. Otherwise, it is recommended to use method 1.

Created with the Standard Edition of HelpNDoc: Free EBook and documentation generator

Application settings backup

All application settings are stored in the "Application settings folder". This location is
explained in this topic, and can be accessed from the main menu under Help->Open
Settings Folder.

These settings are automatically backed up into a single zip file, in the "Settings backup
folder". This folder can be set in the options dialog under Tools->Options->Main->Backup,
under "Application settings backup".

If this folder is left empty, then the settings backup will automatically be saved in the
(notebook) backup directory, in a "Settings Backup" subfolder.

The following image will help you to visualize:

1 - is the main backup folder for notebook backups. 2 - is the folder where the application
setting backups are placed.

In the settings page (Options->Main->Backup), there is a setting to control how many
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backups to keep. This will apply to the automatically saved backups but not to manual
backups. (To be more precise, it will only apply to zip files that have the format of
RNSettings_YYYY-MM-DD.zip)

Note: Only one backup is kept per day. So as settings are (likely to be) saved multiple
times in a day, only the last set will be kept for a given day.

It is also possible to create a backup manually from File->Maintenance->Backup Settings
Manually.

Restoring/Importing a settings backup

Should you need to restore/import a settings backup, this can be done from under File-
>Maintenance->Import a settings backup. Click on the menu item, and then select the
appropriate backup file.

Created with the Standard Edition of HelpNDoc: Free help authoring tool

Page settings

Use page color for tree color

With this option enabled, tree color settings are ignored and the page color is used for each
tree instead. Sometimes it looks nicer for the tree color to be a few notches brighter (or
lighter) than the page color. The "brighten factor" setting takes care of this.

Brighten factor

The "Brighten factor" setting allows you to control how much brighter (or lighter) the tree
color is than the page color when using the "use page color for tree color" option enabled.

0 means the page color is not changed. 100 means the maximum amount of brightness is
added to the page color, in which case the resultant color will always be white. The default
value is 50.

Created with the Standard Edition of HelpNDoc: Full-featured EPub generator

Note settings

Default Content Type

This setting determines what the default note type of a newly created page should be. Once
the page has already been created, you can change the default note type under "Tree
Properties" (F4).

Auto launch virtual note option

If this option is enabled, then when you move to a note that has virtual mode set to
"virtual-open" (i.e. external link), this link will launch automatically.

"Move to a note" in this context means clicking on a link to go to this note, e.g. from search
results, from history or from internal link. However the link will not automatically trigger if
you simply move to this note by clicking on it in the note tree.

Created with the Standard Edition of HelpNDoc: Easily create PDF Help documents

Spreadsheet settings

Highlight/Clickable URLs
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If a cell contains a hyperlink value - i.e. a text value and target value, then it will always be
clickable. However, if a cell only contains a text value but the text happens to be a URL
(e.g. starts with "http://" or "www." or "mailto:") then this setting controls whether the cell
(and text value) should be "clickable" or not.

(Note: Double-click launches URL)

Created with the Standard Edition of HelpNDoc: Produce online help for Qt applications

Indexing settings

The professional version of RightNote allows you to index attachments and links of the
following file types:
.txt, .rtf, .htm/html, .doc/docx, .xls, .csv, .pdf

In the options dialog under the Indexing settings section, you can select which file types
you want to be indexed by default. Further, every note has it's own setting which will
override the default settings.

For example, you may want to set pdf files to not be indexed by default, since often times
these can be large files, and you generally do not need the contents of these file to be
indexed. If you then need a specific pdf file to be indexed, you can adjust the setting in the
attachment viewer.

Created with the Standard Edition of HelpNDoc: Free HTML Help documentation generator

Proxy settings

If you connect to the internet via a proxy server then you need to setup the proxy settings
in the Options dialog under the Proxy section (Main->Proxy).

In most cases you should setup the proxy settings in Internet Explorer, and then select
the "Use Internet Explorer proxy server settings" option.

When connecting to the Evernote server (for Evernote Sync etc..) Internet Explorer settings
are always used - not the Proxy settings from RightNote.

Created with the Standard Edition of HelpNDoc: Easily create EPub books

Tools

Created with the Standard Edition of HelpNDoc: Easily create iPhone documentation

Color Definitions

The "Color Definitions" dialog (Tools->Color Definitions) allows you to setup predefined
foreground, background and mixed color palettes for frequently used colors (for RichView
and RichEdit note types).

When a palette toolbar is "locked" you can't change the color definitions "in place" (i.e from
the toolbar itself), however the toolbar will take up less space.

To setup the foreground and background palettes, choose the number of slots for each
palette from the Color Definitions dialog, and then modify the colors on the corresponding
toolbar. For mixed colors (i.e foreground and background colors) you can additionally set
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the colors in the dialog itself.

You can use the mixed toolbar for foreground and background color definitions as well,
however the intended/dedicated toolbars are easier to use compared to the mixed toolbar.

Created with the Standard Edition of HelpNDoc: Free Web Help generator

Style Definitions

The Style Definitions dialog allows you to create and store a set of predefined styles which
you can quickly apply to text when you edit a document. Usually you will want to select a
section of text and then apply a style to it. You can also apply a style without selecting any
text. This will then change the current style of the cursor.

In the dialog, you can change the font of the currently selected style by clicking on the
"font" button, or simply double-clicking on the style in the list.

Created with the Standard Edition of HelpNDoc: Full-featured EBook editor

Paragraph Definitions

Overview

The Paragraph Style Definitions dialog allows you to setup a number of pre-defined
paragraph styles which can then be easily applied to the current paragraph or number of
selected paragraphs in a RichView note.

One of the key properties of a paragraph style is the ability to "snap-back" to the previously
active style after the ENTER key is pressed. This works very similar to a MS Word type of
heading style. For example the current style is "Times New Roman" 12pt. You start a new
line, and then apply a pre-defined paragraph style that for example includes a font of
"Arial" Bold 14pt. You type the heading then press the ENTER key- now the active style
reverts back to "Times New Roman" 12pt. (Note: If you press Shift-Enter, this creates a
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new line, but does not trigger to revert to previous style).

How to use

Paragraph styles don't have to include font information. They can simply set properties like
line spacing, left/right indent and background color, without affecting the existing font style
of the paragraph. If you select to include font information, then the font of all text in the
paragraph will be changed as well.

Paragraph styles apply to entire paragraphs. If there is no selected text, or if you have
selected only parts of adjacent paragraphs, the entire paragraph or paragraphs will be
affected.

Most often, you will want to check both the "Is heading style" and "Include font info"
options for a heading type of style (one that reverts to previous style after ENTER key is
pressed), and keep both options unchecked for a "simple" paragraph style (i.e. when you
just want to affect the paragraph properties), although you do have the option to have only
one of these checked.

Some tips

There are 2 "small" border and background properties that might go unnoticed, however
they play an important role in getting styles to "look right". These are the text margin and
background padding properties, that can be found in the "Border and Background" dialog,
and their settings appear in the columns marked below of the paragraph definitions dialog.

       

If there is a space between the paragraph border and the paragraph background color, then
usually this can be fixed by making sure that the text margin and padding properties match
(i.e. are set to the same value).

Another point to keep in mind, is that if a paragraph style is not a heading style ("Is
heading style" is unchecked), then usually it's a good idea not to include a border style. This
is because the border will most likely extend into previous and following paragraphs -
resulting in the border lines overlapping:

(Note: This can be avoided by pressing Shift-Enter instead of ENTER when typing in the
paragraph, so that a new paragraph is not created).

Columns

To see what each column represents, run the mouse over the column header to see the
relevant tooltip (hint text).
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Export Style Definitions

When exporting notes, it is possible to merge a number of notes/subtree/entire page into a
single document. In the export dialog (File->Export) click on the "As single merged file"
tab.

As part of the merge you can select to include the note caption. The Export Style
Definitions/Settings allow you to set styles for the captions depending on the node indent
level. In this way you can have "high level" nodes (i.e. nodes close to the root) with a large
font (and other paragraph settings such as underline), and "lower level" nodes with a
smaller font. The style for each level is set up in a similar way to how paragraph styles are
setup: see Paragraph definitions for more details.

At the bottom left of the dialog are some extra settings that can be used to unify the
appearance of the outputted document:

· Use uniform font: The text in all documents will be set to the fontname of the lowest
level font (i.e. Level 9).

· Ensure font size is...: Apply certain rules to font sizes in a given note as specified.

NOTE:
The same Export Styles are used when printing out a document.

Created with the Standard Edition of HelpNDoc: Full-featured Kindle eBooks generator

Customizing Shortcuts

It is possible to change the default keyboard shortcuts that have been assigned to various
actions (via the "Customize Shortcuts" dialog - available under "Tools"), however there
is a little complexity involved, as will be explained.

Firstly: As you should be aware, RightNote has a number of different types of notes. Each
note type (or to be more precise: each note editor) has it's own shortcuts. Because only one
note type is "Active" at a time, you can therefore assign the same shortcut to different note
types. In other words, the program does not prevent you or warn you  from using the same
shortcut in different note types. However the "Customize Shortcuts" dialog, will warn you if
the same shortcut has been assigned more than once within the same note editor (by
highlighting the action in pink).

Also, some actions only become active depending on what window is currently active. For
example, if the Tree window is focused, then "Shift+Enter" will create a new child note. If
however a RichView note type has focus, then "Shift+Enter" adds a "soft" paragraph. (So
this is another reason why the program cannot dis-allow the same shortcut to be used more
than once.)

And lastly, there are a couple of actions that are shown in the "Customize Shortcuts" dialog,
that should not be assigned shortcuts: specifically those that have to do with color pickers /
color palettes - as shown (for example) in the diagram below:

https://www.helpndoc.com
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These type of actions should not be assigned a shortcut.

Therefore: As a general recommendation, it's best to change existing shortcuts where
desired, but be more cautious when assigning shortcuts to actions that don't have any
shortcut assigned to them in the first place. Also, to a large extent, it is the end-users
responsibility to make sure that they do not create hotkey conflicts. (See below "how to get
a list of all shortcuts" - this may help you).

How to change a shortcut

To change a shortcut, click on the action you are interested in. (If a shortcut has already
been assigned, it will be shown in the hotkey edit control (bottom left of the dialog)).
Press the desired hotkey or hotkey combination in the hotkey edit control. (If you need a
special combination click on the "special" button). Then press "Replace" to assign the
hotkey (combination) to the action.

Note: Shortcuts are saved in an ini file (shortcuts.ini) in the settings folder (see Options ->
General for info on where the settings folder is located). To restore the default shortcuts,
close the program and delete this file.

Getting a list of used shortcuts

The "Customize Shortcuts" dialog includes a "Copy" button. This will copy all actions with
an assigned shortcut to the clipboard. The best thing is to then paste this into a spreadsheet
note. You can then add formatting to this list, or even sort the list by various columns. You
could then (select and) "copy to RTF/RVF" and then paste this into a RichView note (if
desired...).

Created with the Standard Edition of HelpNDoc: Produce electronic books easily

Richview List/Bullets Defaults

In a Richview note you can create a bulleted or numbered list in a number of ways:

- from the Toolbar button (Bullets.. CTRL+. ; Numbering... CTRL+,)
- from the Editor right click menu: Bullets and Numbering
- from the Main menu: Paragraph->Bullets and Numbering

After you have created a list you can also change it's properties (e.g. to a different
numbering scheme/layout) using the above menu items. In this way every list can have it's
own individual properties. See below instructions on how to set the default properties of a
bullet or numbered list.

Changing the default list properties

It is also possible to customize the default list properties. Every list you create will then
follow these properties. To do so: go to "Tools->Definitions->RichView List/Bullets
Defaults".

https://www.helpndoc.com/create-epub-ebooks
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For Bulleted lists, stay on the Bulleted tab. To customize the default numbered list, go to
the Numbered tab.

Important: The list that must be customized is the first list in the gallery, i.e. the first item
after "None". (Changes made to any other items will simply be ignored.) Click on the
"Customize" button, to customize the list's properties.

Also note, custom font settings will be ignored for the default list. Instead the current font
in the editor will be used.

Important:
Restart the application for the changes to take effect.

Restoring default list settings

To reset the bullet list settings to the default values you need to delete the "rv_bullets.ini"
file in the settings folder, and restart the application.

To reset the numbered list settings to the default values you need to delete the
"rv_lists.ini" file in the settings folder, and restart the application.

Created with the Standard Edition of HelpNDoc: Create iPhone web-based documentation

Page transfer dialog

The Page Transfer Dialog allows you to move or copy pages from one notebook to another.
The dialog contains four "mini" notebook frames. When you open a file, only it's pages are
shown. Each frame allows you to perform the same file operations for the file it is
associated with, as those available  for a file opened in the main application.

After opening the files you want to work with, drag and drop pages from one frame to
another. When you "drop" (release the mouse), you will be asked if you want to copy or
move the page. Click on the button with the desired action.

Created with the Standard Edition of HelpNDoc: Full-featured EPub generator
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Side by side view

The Floating tree dialog can be used to transfer notes from one notebook to another. The
Side by side view, lines up tree views from a given notebook or different notebooks, and
thereby makes it easy to transfer notes between different pages within the same notebook
or between different notebooks.

The Side by side view menu item is available from under the Tools menu, and is only
available in the Pro version.

Once you open the dialog, press the "Add Notebook" button to add notebooks to the tree
on the left. Place a check next to any pages you would like to see in the main view.

Each tree view that appears, works in much the same way as the floating tree dialog does.
You can drag and drop notes from one tree to the other, and you can also copy/paste
notes in the same way as usual (right click->transfer- >Copy/Paste).

If changes have been made to a file/notebook, you will see that the "Save" icon becomes
colored:

When you click on the notebook in the left treeview, or one of it's pages, you will see the
label showing "Current: ..." - the current notebook, for which the Save and Close buttons
apply. Press on the Save button to save changes for this notebook, or Close - to close
without saving.
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Screen Capture

The screen capture tool allows you to take a snapshot of a selected region of the screen.
Most often you'll be capturing and copying text snippets into RightNote from the clipboard.
Sometimes however, you want to specifically capture an image on the desktop, or else for
some reason you can't copy text from a given application. In that case you may need to
settle for a screen clipping, instead of the actual text.

The screen capture tool is activated with the global hot-key associated with it (by default
Shift+Ctrl+F11, and can be changed in options dialog). As soon as you hit this key, an
image of the desktop is captured and then set to take up the whole screen. It may look like
nothing has changed, but in fact you're only looking at a screenshot of the desktop - you
can't press any buttons or anything else. All you can do is select a region on this "image".

To select a region, left click the mouse, drag, and then release. Once you have a selection
rectangle, you can:
· move it: by moving the mouse into the rectangle (the cursor will change to the "move"

cursor), then left click and drag the mouse, or/and
· change it's dimensions: move the cursor over the border of the selection rectangle until

the cursor changes to the "resize" cursor. Then left click and drag the mouse, to change
that side's or corner's dimensions.

To "accept" the current selection press ENTER.
To cancel press ESC.

https://www.helpndoc.com/feature-tour
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If you press ENTER, then the current selection will be copied to the clipboard. To paste this
selection, go to the desired destination RichView note and then paste (Ctrl+V).

Created with the Standard Edition of HelpNDoc: Easily create CHM Help documents

Global functions

Created with the Standard Edition of HelpNDoc: Free help authoring tool

The global database index

The Global Database Index stores some basic information for each note from all notebooks
that have been used in the application. This information is then used in the Global note
history and Global tags search dialogs. For example it stores the note caption, last viewed
and last modified dates and tags. It does not store the note content.

The index includes all files in the Most Recently Used files list, Favorite Files list, files in the
(RightNote) Evernote folder, and also any files from folders listed in the "Multi Notebook
Search" settings (found under Tools).

The global index will only work with notebooks that are updated to the latest RightNote file
version. Files that are not updated to the latest version will be skipped. A file is updated to
the latest version by simply opening it in the latest version of RightNote. You can also
update all files in one go, using the "File > Maintenance > Update All Notebooks"
command. If, while updating the index, some files were skipped due to an outdated file
version, an info icon will appear in the Global Tags Search dialog, alerting you that there is
some issue with the index. You can click on this icon for more information. You can also
view the Global Database Log from under the "Help > Debug > Global Database Log"
menu item.

Excluding specific files from the Global Index

Specific files or folders can be excluded from the Global database index. This can be
achieved from the dialog under Help->Debug->Global Skip File List.

Handling of protected content

If a note is in a protected page or in a protected notebook, then the note caption is not
stored. If a notebook is protected at the file level, then page captions, note captions and
also all tags are not stored. In other words the Global Database Index is primarily intended
for, and works best with unprotected notes. The Global Tags Search feature will not work
with notes from a protected notebook. The Global Note History feature, will show that "you
accessed a note from a protected notebook", however, it does not show what the note
caption was.

Q. How can I encrypt my information and still use the Global index?

As mentioned above, the Global Database index will work best with unprotected files, or
where only individual notes are protected. If you want to encrypt your entire RightNote file,
it is suggested that you use a 3rd party tool for this purpose. For example, VeraCrypt
creates encrypted drives that can then be mounted onto your files system. In this way the
data is completely protected by VeraCrypt, but once you provide the password it is mounted
onto the file system, and can be accessed by RightNote as a normal unprotected file.

Created with the Standard Edition of HelpNDoc: Easy EBook and documentation generator
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Global tags search

The Global Tags Search dialog, lets you search for any tag across all RightNote notebooks.

Double click on the desired tag to move to the tag search results view. You can also type in
the filter box to filter the list of displayed tags. If the first character in the filter box is a
back tick "`", then the filter will match the beginning of the tag. Otherwise the filter will
match anywhere within the tag name.

When viewing the tag search results:
· If you click on a related tag (green link), it will be added to the tag search criteria, so

that the results show the previously selected tag(s) plus this one.
· If you click on a tag in the tag search criteria list (shown just under "Start new search"),

then that tag will be removed from the tag search criteria list.
· If you click on a notebook (blue link), the results will be limited to that specific

notebook. Furthermore, the results will be shown in a hierarchical tree

Double click on a note in the results list to bring up the Note Editor dialog, from which you
can view or edit the note content, or move to that note by opening it's notebook.

As mentioned in the global database index topic, if there was some problem updating the
global index, an info icon will be displayed. This icon will alert you that there are some old
RightNote files that need to be updated to the latest file version.

Note: This feature is only available in the Pro version.

Created with the Standard Edition of HelpNDoc: Create cross-platform Qt Help files

Global note history

The Global Note History dialog gives you an overview of recent note activity within
RightNote. The display is limited to the last 2 months, and can be sorted by last Created,
Modified or Viewed date using the button drop down in the top right corner.

You can also filter the display by Notebook or Tag by clicking on the relevant button in the
top middle of the dialog. You will notice that the first item in the shown list is "All". Once
you click on a Notebook or Tag (further down in the list) to filter the display, you
subsequently remove the filter by clicking on "All".

If you click on a note in the display, that will bring up the Note Editor dialog, from which
you can view or edit the note content.

In the top left is a filter box. If you type in this box, the display will be filtered to any notes
whose caption matches the typed text. In this case, the display is not limited to any time
period, but instead will search through all notes in the global database index.

Note: This feature is only available in the Pro version.

Created with the Standard Edition of HelpNDoc: Produce electronic books easily

Global search dialog

While the global search function in the Resource Panel (Ctrl+G), helps you find what you're
looking for very quickly, and works fine in "most" cases, the search results display size is
somewhat limited.

For a more spacious view, we have added a separate Global Search dialog (available under
Tools, with default hotkey: Ctrl+Shift+G), that provides an enhanced and more spacious

https://www.helpndoc.com/feature-tour/create-help-files-for-the-qt-help-framework
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search experience. Other than that, the way the search works is almost identical to the
Resource panel global search.

The search results are intended to be displayed in two columns. The display dimensions
should be adjusted so that the search results pane is roughly the same size as the note
content pane.

You can also adjust the height of the "Pages" and "Notebooks" sections. We found that it
worked well to show two lines of results, and to scroll if necessary for further results.

If you press Alt+D, this will toggle display of search result details (the button next to close).
Otherwise details will be shown when the number of search results is less than the "Include
FTS samples if less than XX results" setting found under Tools->Options->Main->Search.

If you right click on the search results, some further options are available, such as to show
a quick tree view of where the note is located, as well as to include time and path in the
display. Note: Including Tree Path in the display will slow down the search results.

Note: The Global Search dialog is only available in the Pro version.

Created with the Standard Edition of HelpNDoc: Qt Help documentation made easy

Icon Manager

Created with the Standard Edition of HelpNDoc: Full-featured Help generator

Introduction

The icon manager allows you to:
· select an icon from the application icon database (called the System database) or from

the custom icon database (called the Custom database).
· Add or remove icons from the custom database.

https://www.helpndoc.com/feature-tour/create-help-files-for-the-qt-help-framework
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· setup the application icon palette which can include icons from both the System and
the Custom databases.

Icons cannot be added to or deleted from the System database. However, folders within the
system database can be created and moved around, and icons can be moved from one
folder to another. In other words you can re-organise the icons if you so desire, but you
cannot add or remove icons from the system database.

To move an icon from one folder to another, simply drag it from the list of displayed icons
and drop it onto the folder you want to move it to.

The underlying design of the icon database

This may not be initially obvious, however after taking some time to get used to how the
icon database works and how new icons are imported, you will see there is a specific
underlying design to the icon database.

(This does not apply to individual icons that you may find or have, however..,) Most icon
sets that are available, are made up of the same icon in various sizes. Let's take as an
example the Glyfx common toolbar icon set that is available for free from www.glyfx.com.
This set includes a mail icon in various sizes, e.g. mail_16.png, mail_24.png, mail_32.png
etc..

When importing icons, each imported icon has it's own unique "id", by which it can be
uniquely identified within the database. However, it would be useful if the application had
an idea that mail_16.png, mail_24.png, mail_32.png etc.. are all actually the same icon,
just in different sizes.

The way it can do this is by all "same" icons having the same name (or caption) within a
given icon set. To accomplish this, when importing the icons certain parts of the original
filename need to be replaced. So for our example, _16, _24, _32 need to be removed (i.e.
replaced with "" - nothing). (All file extension are never included in the imported icon
filename, so .png is not a problem). In this way the caption of all these distinct icons would
end up being the same.

(As an example application: if you selected an icon -  and then the application needed or
wanted to display a larger version of this icon, it would be able to work out which icon to
use. Although no specific application has been implemented yet, there are some plans for
such a feature, so it is useful to keep this possibility available).

Anyhow, it makes viewing and searching for icons alot simpler if all the extraneous parts of
the icon filename are removed, and all "same" icons can be referred to with the same
name.

More information about the import process and some specific examples can be found in
subsequent topics.

See also: Working with icons

Created with the Standard Edition of HelpNDoc: Free EBook and documentation generator

Selecting an icon

Below is an image indicating the various parts of the icon manager:
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The "Left panel" consists of a number of elements that setup a filter, which determines
which icons are displayed in the "Icon list". Starting from the bottom upwards:

· a size filter, determines what size icons to include in the icon list. (Note: only one size
can be selected at a time. Also, when selecting an icon for notes or pages etc., only size
16 is available. When selecting an icon to include in a RichView note type, all sizes are
available).

· Iconset filter: which icon sets to include.
· Folder filter: contents of which folder to display if the "filter selector" is currently set to

"folders". If the filter selector is set to "favorites" or "palette" then the current folder is
ignored.

When a search is initiated from the search box, the current folder is ignored, however all
other filters are applied.

Double click on the desired icon to select it for use in the application.

Created with the Standard Edition of HelpNDoc: Easily create CHM Help documents

Icon database settings

In the database settings, you can setup a "root folder" that will be used for when icons are
imported by path only. This is discussed in more detail in the Batch Import topic.

If you delete a large number of icons from the database, then the "Compact" action
removes unused space from the database, and reduces the database file size.

Created with the Standard Edition of HelpNDoc: Free PDF documentation generator
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Importing Icons

This topic explains how to add icons to the Custom database. (As mentioned previously, you
cannot add icons to the System database).

Whenever adding icons, you first need to select:
- the iconset you want the icons associated with and
- the folder (or root folder) you want to import the icons into.

If these don't yet exist you need to create them. Add new folders with the "Add sibling" or
"Add child" actions,

and add new iconsets with the "Add iconset" action, found on the Left panel.

Now you're ready to add icons.

If you are only adding a few icons you can use the "Import Image" action (above the icon
list). When importing large number of icons, or entire icon sets, it is highly recommended
that you use the "Batch Import" action, since the batch import dialog gives you much more
control over the import process.

If you import a few icons using the "Import Image" action, then you may want or need to
rename the icon caption(s) after import to remove extraneous parts of the caption, e.g.
rename "mail_16" to "mail".

The next topic explains how to use the batch import dialog.

Created with the Standard Edition of HelpNDoc: Full-featured Documentation generator

Batch Import

The batch import dialog helps you easily import large number of icons or entire iconsets
into the custom icon database.

https://www.helpndoc.com
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The dialog performs 2 main functions:
1.  It allows you to specify import and export filters.
2.  Specify "replace".."with" strings.

Include and Exclude filters

After selecting the root folder from which you want to import the icons, the filters will limit
which files are included in the import. (Note: even without a filter, only bmp, png and gif
image formats are currently supported.)

For example, some sets include the same image in various formats, e.g. bmp, png, gif etc..
There is no need to import all the different formats. Png offers higher quality than the other
formats so it's a good idea to only import the png files. As you can see in the "Include
filter", the "png" entry ensures that only files that match "png" are included in the preview
file list.

Note: As in the image above do not include quotation marks in the filter text!

Also, many sets include "hot" and "disabled" (greyed out) versions of the same icons. The
example screenshot shows how to exclude these files from the list, by adding the entries
"_h" and "_d" to the "Exclude filter". (Note: This applies for Glyfx icons, and is quite likely
to be different for other icon sets.)
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Enter only one filter entry per line. Note: Filters are applied to the entire file path not just
the filename.

Replace..with strings

You can also specify "replace..with" string pairs, which will be applied to each filename if
applicable. This ensures that "same" icons (i.e. the same image but in a different size) end
up having the same name (caption). This makes searching for icons a lot easier and also
makes it possible for the application to "see" a relationship between these icons.

In the example above, "_" is replaced with " " (a space), and "16", "24", "32" etc. are
replaced with "" (nothing). In this way filenames like "mail_16.png", "mail_24.png",
"mail_32.png" will all end up being named "mail" within the database. The preview file list
also shows (in the last column: Image Caption) what the final image name will be after
"replace..with" string pairs have been applied.

Import path only

If this option is checked then the actual images aren't imported into the database only a
path reference to the image file on disk. This will result in the database size being much
smaller than if the actual images are imported especially if the images are large. Of course
you must make sure that the external files are kept in the same location in order for the
path references to remain valid.

Note: In the "database settings", you can set a root path for image file paths stored in the
database. If the location of this root folder should change, you can update the root path in
the database settings, and all relative paths in the database will still be valid.

Path level for new folder

Often when you import a whole library of icons, the icons are grouped into categories by
folder. If you look at the preview file listing, you will notice that a certain level of the path
contains the current category. For example,

when importing icons from the open source "Crystal Project", you will see that (in this case,
depending on where the root folder starts) the second "level" of the path contains the
category. If you specify a path level in the "Path level for new folder" spin edit, then a new
folder will be added automatically as a child to the main folder you selected to add the icons
to.

If you find this difficult to follow, check out the batch import example for a more complete
illustration of how this all works.

"Undo"ing an import

Whether you import icons individually or by batch, in both cases you can undo an import
operation. Click on the "delete batch import" action, select the relevant batch and then click
on delete.
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Warning: A delete action cannot be undone.

Created with the Standard Edition of HelpNDoc: News and information about help authoring tools and
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Batch import example

Let's run through an example of importing an entire iconset into the custom icon database.

For this example we will be importing the crystal icons from the crystal project available at:
http://www.everaldo.com/crystal/?action=downloads .

Download the file (http://www.everaldo.com/crystal/crystal_project.tar.gz) and save to the
directory of your choice. For this example I've saved the package to my "C:
\Downloads\Icons" folder. Unzip the package.

Open the Icon Manager and click on the Custom Database (if you're not there already).
Click on the "database settings". For the Root path enter: "C:\Downloads\Icons" (for the
purposes of this example - replace with the root folder you use for your icons).

First create an iconset named "Crystal" (in the iconset list) and a root folder named
"Crystal" (in the folder tree view). Select the iconset and the folder, then click on "batch
import".

Click on the "..." button to select a folder, and navigate your way to the crystal icon folder.
My root folder now looks like this: C:\Downloads\Icons\crystal_project\crystal_project.

Check "import path only" and uncheck "include icon preview" (this will slow things down if
we're dealing with a large number of icons). Set include filter to "png". Click on load. Now
we can see that the path level that contains the icon category is at level 2. So set "path
level for new folder" to 2. Add an entry to the replace..with section: replace "_" with "
" (space). Click refresh filters.

Ok that's it. Click on the "Import" button and a progress bar will show the progress of the
import. When you're done close the dialog.

If something went wrong, delete the import via the "delete batch import" dialog, and try
again!

Created with the Standard Edition of HelpNDoc: Produce Kindle eBooks easily

Setting up the Icon Palette

As you view icons in the icon list (of the Icon Manager), the "add to palette" and "remove
from palette" actions allow you to add an icon to or remove it from the palette respectively.
You can also check or uncheck the "on palette" property of the icon displayed in the icon
properties inspector (on the right).

(Icons on the palette are displayed when you try to select an icon for a note in the note
tree).

Icons from both icon databases (system and custom) are used to make up the icon palette.

Notes:
- Icons are sorted alphabetically.
- The icon palette supports up to 400 icons (20 rows x 20 cols).

https://www.helpauthoringsoftware.com
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Inserting an icon into a note

See the notes in the RichView note type topic for information on how to insert an icon into
a RichView note.

Created with the Standard Edition of HelpNDoc: Free help authoring tool

Clipper
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Usage

The RightNote clipper allows you to easily capture content from other applications and send
it to RightNote.

You trigger the clipper by selecting text in an application, copy to clipboard (Ctrl+C) and
then pressing one of the global clipping hotkeys (see below). The content will be sent to
RightNote and you will see a little alert window notifying you of the current progress and
when the capture has completed.

Note:
· You cannot clip more than one thing at a time. Wait for the current clip operation to

complete (as indicated by the progress in the alert window) before clipping something
else. Once you see "New Content Added" the capture has completed, and you can start a
new one: i.e. you don't need to wait for the alert window to disappear.

Global Clipper Hotkeys

The clipper hotkeys can be found in the Options dialog (Tools->Options) under the Global
Hotkeys section:

"Clip to New Note" means captured content will be inserted into a new note.
"Clip to Current Note" means captured content will be appended to (added to the end of..)
the current note.

To change a hotkey, click on the hotkey panel (it shows the hotkey that has been setup for
this action) and then select the desired hotkey combination from the dialog that comes up.
To disable a hotkey make sure the "Enable this hotkey" checkbox is unchecked in this
dialog. You should ensure that the hotkeys don't conflict with global hotkeys that may have
been setup by other applications, otherwise they may not work.

Clipper Options

The clipper options dialog (found under Tools->Clipper Options), allows you to choose a few
options that control how the clipper works:

New Clip Insert Mode: Choose whether a new note gets added as a child of the current
note, or gets added to the bottom of the current page.

Auto-Copy when press Clipper Hotkey: If this option is enabled, when you press the
Clipper hotkey (by default Win+V), the content is automatically copied and pasted into
RightNote. In other words, this saves you having to press Ctrl+C before pasting.

KNOWN ISSUE:
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If Auto-Copy is enabled, in some cases the copy step stops working and you then receive a
"Warning: Nothing clipped" message. Because of this, it may work better to disable this
extra feature and manually copy content (press Ctrl+C) before pasting into RightNote
(Win+V). This method is more reliable and is recommended if you are encountering the
above mentioned problem (until such time that we can find the cause of this problem).
(Note: This option is also available from the RightNote trayicon popup menu)
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Templates

Clipper content is added by way of a pre-defined template. You can select which template to
use in the Clipper Options dialog (under Tools). If you don't want to use any template, you
can select the "empty row" option (available in the drop down list).

Advanced users may want to modify the default Bookmark templates or create their own.
For an example of supported variables take a look at the "BookmarkXX.rvf" templates in the
SystemTemplates folder (My Documents\My RightNote\SystemTemplates). 

Templates can be edited with the RichViewEditor utility that is available at:
http://bauerapps.com/files/RichViewEditor.zip

Created with the Standard Edition of HelpNDoc: Benefits of a Help Authoring Tool

Bookmark clip

You will find RightNote's bookmark clip action to be very useful for saving webpage
bookmarks into your notes. A bookmark includes a small thumbnail view of the webpage, as
well as the webpage title and url.

Bookmark

Title: Wikipedia

Visited on: 21 February 2016 12:00 PM

Notes: Example bookmark clip..

Source: https://www.wikipedia.org/  

The default hotkey to take a bookmark clip is Ctrl+Shift+F7. When you are viewing a
webpage in a browser and press this hotkey, a bookmark of the webpage will be added to
the current note in RightNote.

Note 1: 
Currently supported by Internet Explorer, Firefox, Opera and Google Chrome. 
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Note 2: 
For the bookmark feature to work with Chrome or Opera, version 4 of the .NET Framework
must be installed on the computer. This version is usually already installed when running
Windows 7 or later.

If the correct version is not installed on your computer, the clipping will not work. You can
download this version of the .NET Framework from here:
https://www.microsoft.com/en-za/download/details.aspx?id=24872
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Clipper dialog

The clipper dialog makes it quick and easy to file away new clips, bookmarks or webpages to
their desired destination, and also apply desired tags. Especially if you want to save the clip
to a notebook that is not currently open, you no longer need to open the notebook, go to
the desired page, etc.. etc.. . in the Clipper dialog, simply select "Unfiled", the desired
notebook and page and press "OK", and the clip will be saved to the correct location.

There are a few points that could do with some explanation and so they are listed below:

1. You can select to save to the current Path ("Use Path"), which will save to the current
location in the currently opened notebook. If you select "Unfiled", this will save to the
selected notebook/page under a parent note called "Clippings".

2. The (drop down) list of notebooks is obtained from the list of favorite files as well as the
last 5 opened notebooks. If you want to include a specific notebook in this list, click on the
"..." button (which is visible when "Unfiled" is selected).

3. You will notice that the first entry of the pages drop down list is blank. If selected, then
the clip will be filed to the first page in the selected notebook. So for example, you could
have a notebook called "Inbox.rnt". Then in the clipper dialog, you just select "Inbox.rnt",
and don't need to worry about which page.

4.You will see a tags edit box, which allows you to enter tags for the clip. The drop down list
of available tags matches the currently selected notebook. Pressing ENTER, comma or semi-
colon will accept the current text as a tag. If the edit box contains no text, pressing ENTER
will close the dialog (i.e. be the same as clicking on the OK button).

5. The clipper dialog can be disabled/enabled from the main RightNote tray icon menu.

6. The clipper dialog is only available in the Pro version of RightNote.

Important #1:
The clipper dialog can work with notebooks protected with a file password, however you will
need to enter the file password multiple times as the clip is saved, unless the protected
notebook is the currently opened notebook in RightNote.

Important #2: 
You cannot save a clip to a page that is protected with a note password, unless that page is
the current page, you are saving with "Use Path", and the page has already been loaded.

Created with the Standard Edition of HelpNDoc: Full-featured multi-format Help generator

Clipper log

If the application is not able to capture a webpage or clip, you will see an error message pop
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up saying: "No browser address detected", or "Warning: Nothing clipped" respectively.
When this happens, RightNote will add some debug information to a file called
ClipperLog.txt, which is located in the debug directory. (You can open the debug directory
via Help->Debug->Open Debug Folder).

Should the problem persist please send this log file to support for further investigation.
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Webpage capture and bookmark clips in Firefox browser

RightNote uses different techniques to obtain the current webpage address (technically
called the "url") from the different browsers.

For Firefox, it specifically needs to know the text displayed in the browser's address bar
when it is empty, as in the image below:

This text may change over time (previously it was "Search or enter address") or may be
different if you are using a non-english Firefox installation.

To handle such anomalies, a specific setting has been added under Tools->Options->Main-
>Browser.

As the text there says.. In order for webpage and bookmark capture to work correctly the
below fields must match the text that appears in Firefox when the address bar is empty.

The same holds true for "Waterfox", which is another browser based on Firefox.

Created with the Standard Edition of HelpNDoc: Full-featured EBook editor

Evernote Integration

Created with the Standard Edition of HelpNDoc: Full-featured multi-format Help generator

What is Evernote?

Evernote allows you to store notes (and more) in the cloud in a way that you can access
these notes from any browser or device. You can send notes to Evernote and access them
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from Windows, Mac, Internet Explorer, Firefox, iPhone, iPad, Blackberry and Android.

In Evernote you mainly organise your notes via tags. (There are notebooks and stacks of
notebooks as well).

The RightNote - Evernote integration allows you to store Evernote notes in a tree structure.
In this way you can have the best of both worlds: Access your notes from anywhere with
Evernote. Organise and structure your Evernote notes in RightNote.

For more information on Evernote, visit their website here: www.evernote.com.
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Why use Evernote?

So why would you want to use Evernote? and specifically, why use Evernote with
RightNote?

Access your notes from "anywhere"

The most obvious benefit to syncing notes with Evernote is that you will be able to then
access them from any place where you can access Evernote notes - which is almost
anywhere. This includes access from common browsers (Internet Explorer, Firefox, Chrome,
Safari.), and also the many clients apps that Evernote offers: for Windows, Mac, iPad,
iPhone, Android and Blackberry. Some other less obvious (but still very powerful) benefits
are mentioned below.

Search text in images

Even before Evernote moved to the cloud (when it was a Windows only app) it included a
distinctive and very powerful feature: the ability to search text found in images - and do
that very well too. With the Evernote integration, you can now enjoy this benefit in
RightNote too. When an Evernote note is synced with the service, the text information for
embedded images is also obtained.

This can be very useful, for example: You want to save some settings that exist for a given
program. You cannot get the settings in text format, but you can take a
screenshot/screenclip of them. You do this and then save the picture in RightNote. But now
how do you find that information later on? Well, if you are diligent you may include some
text in the note aswell describing the picture. If you don't, having the screen clip indexed
for text information can be very helpful when you need to find that information at some
time in distant the future.

Evernote web clipper

Being able to access your notes from any browser or device is only one side of the Evernote
coin. Very useful as well, is having the ability to add notes to your account from any
location. E.g. You are away from your desktop (where you use RightNote), and come across
some info you would really like to add to your RightNote information database. The browser
you are using has the Evernote clipper installed. Great. Login to your account - clip to
Evernote - Log out, and when you come back to your desktop, you can easily transfer this
information into a RightNote notebook.

The Evernote App Center

Using the Evernote service means that besides having access to the Evernote clients and
web clippers, you also have access to a multitude of other services that integrate with
Evernote. You can view these services at the Evernote website.
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Why use RightNote with Evernote?

If you are an Evernote user, using RightNote can benefit you in the following ways:

Improve your memory and learning ability

Storing your notes in an orderly and logical layout can help you learn and absorb the
material more easily. It can improve your insight and understanding of your notes as you
see related topics next to each other, and thereby make deeper logical connections between
your notes.

Likewise, it makes it easier to present and teach this information to others.

Especially if you are a lecturer or teacher and you want to present your notes in a logical
and structured order, it is important to arrange and present your notes in a hierarchical
fashion. This can be done via RightNote.

You can also create a hierarchical table of contents of your notes and then sync this note
back to Evernote.

Export your notes in a structured export format

Once you have organised your notes into a tree, you can then take advantage of
RightNote's various export formats that allow you to export your content while preserving
the hierarchical layout of your notes. (More options coming soon...)

Notebook level sync

The Evernote integration is designed in a way that you can be involved with Evernote as
much or as little as you want. You do not need to sync your entire Evernote account with
RightNote (which may take up a lot of space or time..). You could for example, only keep a
few notebooks in sync with Evernote if that suits your needs best. (This is controlled in the
Evernote Manager available under the Tools menu).

Work with multiple Evernote accounts simultaneously

RightNote allows you to sync and search through multiple Evernote accounts
simultaneously when using the multi notebook search feature.

Created with the Standard Edition of HelpNDoc: Free Kindle producer

How is RightNote different to Evernote?

There are a few important differences between RightNote and Evernote that you should be
aware of:

· In Evernote you do not concern yourself with how/where your notebooks are stored on
the computer. You only access them via the Evernote interface. With RightNote, every
notebook is a separate file on the computer (by default stored in the (My)
Documents\My RightNote folder). You open a notebook by going to File->Open and
selecting the file from it's location on the computer. The cloud icon on the toolbar also
gives you quick access to your Evernote notebooks grouped by account.

· In RightNote not all notebooks are "Evernote" notebooks. You can create standalone
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notebooks that have nothing to do with Evernote. Evernote notebooks are specifically
selected via the Evernote Manager, and these notebooks are stored in a specific folder
(Documents\My RightNote\Evernote).

· Also, RightNote has different note types such as Richview, Spreadsheet, Source code,
Evernote etc.. Only notes that are of the Evernote note type are synced with Evernote.

· In Evernote, notes are mainly grouped together via tags. In RightNote, there are also
tags, however you initially organise your notes in a tree structure. When you import
your notes from Evernote into RightNote, you will see they are not arranged in any way.
You need to manually organise and layout your notes as required. There are some tools
that will help you in this process. The Organising added notes topic provides more
information.

Created with the Standard Edition of HelpNDoc: Free Kindle producer

Prerequisites

The Evernote integration feature requires that you have the Microsoft .NET Framework 4
Client Profile installed on your computer. This version of the Framework is usually already
installed on your computer when running Windows 7 or 8.

If the correct version is not installed on your computer, the program will notify you of this
when relevant.

You can download this version of the .NET Framework from here:
https://www.microsoft.com/en-za/download/details.aspx?id=24872

Follow the instructions given there to download and install this version of the .NET
Framework

Created with the Standard Edition of HelpNDoc: Easily create Help documents

Getting Started

To start you must of course have an Evernote account. If you don't have one yet, create an
Evernote account at www.evernote.com.

The Evernote (Account) Manager and Password protection

Evernote does not allow just any program to access your account data. You need to first
grant them permission to do so. This is done in the form a token or key, which allows
RightNote to access your Evernote data, and which the program obtains when you click on
the "Authorize" button (mentioned below.) This token or permission can also be revoked at
any time from the Evernote online web interface.

Within RightNote, all such tokens are protected with a global password that you setup the
first time you try to open the Evernote Manager. This password will protect the Evernote
tokens so that no one else can use them without the password. Once you have setup a
password, you will need to enter it at least once before you can open the Evernote Manager
or perform a sync. (In the installed version, the program gives you the option to store the
password in a secure and encrypted place in the registry, so you do not need to enter it
each time the program runs).

Add an Account and select notebooks to sync

1. Click on Tools -> Evernote Manager
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2. Enter a password and hint to setup the above mentioned password.
3. In the Evernote Manager click on Add Account. Type in your Evernote account name.
4. Click on Authorize, and then follow the steps to allow RightNote to obtain an Evernote
token for this account. After you authorize successfully, the program will refresh the list of
notebooks in this account.
5. Place a tick next to each notebook you want synced with RightNote.
6. Press OK to save the changes.

Sync and synced notebook location

When you press Evernote Sync All (Under Tools), the necessary RightNote notebooks will
be created in the Evernote storage folder and then synced with their Evernote
counterparts.

The Evernote storage folder is located under:
My Documents\My RightNote\Evernote\.

A separate folder is created for each Evernote account, and a separate RightNote file is
created for each notebook that is synced with. So for example a notebook called Recipes
from account MyENAccount will be stored in the file:
My Documents\My RightNote\Evernote\MyEnAccount\Recipies.rnt

You can easily open a synced notebook from the Cloud icon menu on the Favorites toolbar:

The Evernote quick access drop down menu:

Which notes are synced?

Only notes of the Evernote note type are synced. Other note types (e.g. Richview,
spreadsheet, source code) are not synced.

When notes are added to a RightNote notebook (i.e. imported from Evernote) they go into a
page titled Sync Inbox. This text can be changed in the settings. (under Tools->Options-
>Editors->Evernote).
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Token security

As mentioned in the previous topic, the Evernote token(s) that you obtain are protected
with a global password that you setup the first time you try to open the Evernote Manager.
You need to enter this password to open the Evernote Manager or perform a sync (for the
first time).

When entering the password (if not present) you are given the option to store the password
on the computer so that you do not need to enter it each time. (This option is not available
in the portable version). If you choose to do so the password will be stored in a secure
location on the computer.

At the bottom of the Evernote Manager the following security options are available:

· Change Evernote Manager Password - (simple enough..)

· Remove Evernote Manager Password from storage - This does not change the
password in any way. It simply removes it from local storage as mentioned above. You
then need to enter the password the first time you want to sync or open the Evernote
Manager per run.

· Remove Token for Current Account - This deletes the Evernote token for the current
account from the computer. You will not be able to sync this account unless you get
another token (via the Authorize button).

· Remove Token for all Accounts - as above, but for all accounts in the Evernote
Manager.
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The sync process

The sync process is complete and works "Both ways", meaning:

· Changes made to a note in RightNote will be transferred to Evernote and vice versa.
· New notes in RightNote will be created in Evernote.
· New notes in Evernote will be created in RightNote.
· Notes deleted in RightNote will be deleted in Evernote. (They will be sent to the Trash

bin - they will not be deleted permanently).
· Notes deleted in Evernote or moved to a different notebook will be deleted from the

current RightNote notebook.

Sync conflicts

Note however, that for a single given note, the sync is only in one direction. If changes
have been made in RightNote and Evernote to the same note, this will result in a conflict
when trying to sync. For example, if you add tags to a note in RightNote, and change
content of the note in Evernote, one of the 2 is going to be lost after a sync. At this point,
when there is a conflict, the changes in Evernote will be transferred to RightNote, and a
"backup" of the original RightNote note will be created as a child of the affected note. You
should check this note for differences as soon as possible and then delete.

Disable sync for specific note

If a note is set to not sync (in the Note Properties), then it will not be included in the sync.
If you then delete the note, it will not be deleted in Evernote. (If you perform sync again,
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then the note will be added as a new note...).

You can also set this property for a number of notes at the same time by selecting them,
then right-click and go to: More... -> Exclude from Evernote sync.

Changing notebook name

If you change the name of an Evernote notebook then:
· If the file being synced with is in the Evernote storage folder, then the RightNote file

name will also be changed to this name.
· If the file is not in the Evernote storage folder, then the RightNote file name will not be

affected.

Moving notes from one notebook to another

You can move notes from one notebook to another and the changes will be applied the next
time you sync. This is true for both RightNote and Evernote, i.e. If you move notes from
one RightNote notebook to another, the changes will be applied in Evernote, and vice versa.
(For RightNote, both notebooks need to be linked to an Evernote notebook).
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Creating a new Evernote notebook

Note: Currently you cannot create a new Evernote notebook from within RightNote. 

To accomplish this you need to:

1. Create the notebook in Evernote
2. Then sync (in Evernote)
3. Then in RightNote, refresh the list of notebooks in the Evernote Account Manager for

the relevant account and select to sync that notebook.
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Evernote sync rate limits

In an effort to ensure the best possible performance of the Evernote service, Evernote has
recently placed a limit on how much data can be transferred by third party integrations in a
given hour period.

If the limit is reached, then the user needs to wait a certain amount of time until they can
sync again. If you reach this limit, the program will inform you accordingly and also tell you
how long you need to wait before you can sync again.

Under normal circumstances, when syncing changes between Evernote and RightNote you
are unlikely to hit this limit, i.e. when transferring a few notes to or from Evernote.

However, it is quite possible that you be hit by this limitation when performing your first
sync with your Evernote account, and there are a large amount of notes to transfer.

To avoid this problem, Evernote has made a special allowance for 24 hours after you first
authorize RightNote to sync with Evernote, where the rate limit is increased significantly so
that the rate limit is not reached.

Created with the Standard Edition of HelpNDoc: Easily create PDF Help documents

https://www.helpndoc.com/feature-tour
https://www.helpndoc.com/feature-tour
https://www.helpndoc.com/feature-tour


RightNote

101 / 114

Warnings and precautions

Unique notebook names

When you select to sync an Evernote notebook in the Evernote Manager, a corresponding
RightNote file will be created for this notebook. This creates a potential problem. In
Evernote, a notebook can contain any character, however, Windows does not allow certain
characters in a filename (e.g. \ / : * ? " < > | ). When RightNote creates a file, it will
replace these problem characters with a "_" (underscore). You should ensure that all
notebook names will be unique after such a replacement occurs, otherwise the Evernote
sync will be aborted!.

For example, if you have two Evernote notebooks: *notes, and ?notes (and you select to
sync both of these notebooks...), RightNote will not be able to sync since both notebooks
would end up being the same RightNote file i.e. _notes.

Created with the Standard Edition of HelpNDoc: Free Web Help generator

Additional way to link a notebook

This is an advanced topic. Under normal circumstances you will have no need for this
feature. It is provided as a compatibility feature to version 2, and also may be useful in
some advanced use scenarios.

The usual and straight-forward way to setup a link between a RightNote and Evernote
notebook is through the Evernote Manager. When you place a tick next to an Evernote
notebook (shown in the current Account), RightNote will automatically create the
corresponding file and setup a link between the two.  In this case the RightNote file (i.e
notebook) is created in the Evernote storage folder, and also every Evernote notebook is
linked to only one RightNote file.

It is however possible to setup a link (or additional links) between a RightNote and
Evernote notebook, where the RightNote file is not in the Evernote storage folder. This is
done in the File Properties dialog (File->File Properties), and creates a link for the
currently open notebook.

First, make sure you have already added your Evernote account in the Evernote Manager
dialog, and that the list of displayed notebooks is up to date (If required press on Refresh
Notebooks).

Then in the File Properties Evernote section click on the drop down lists and select the
relevant account and notebook. You will notice that when you click on a notebook, the
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Notebook GUID field is set. This field is used in the sync process, so that even if the
Evernote notebook name changes at a later point, the file will still sync.

Note: When you click on Sync All, only files in the Evernote storage folder, and the
currently open notebook will be synced (and not every file that has an Evernote link).

Created with the Standard Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1
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Evernote note type icons

Evernote notes work just like other notes. Here is the meaning of the content type icons
that appear in the left tree column:

Note is in sync with the Evernote account

Some changes have been made to this note in RightNote (i.e. require that you
perform a sync to update contents in Evernote)

The note has been marked to not be included in Evernote sync's. (See Note
Properties->Sync)

The note is locked in RightNote. When you sync to Evernote you will be prompted
for the (RightNote) password. If this is not provided, the note will be skipped from
the sync. The content of this note is only protected in RightNote - it is not protected
in the Evernote account.

(Warning: It is advised that you do not protect Evernote notes, since such notes
may be handled differently in the future).

In the Options dialog, there is an Evernote section.

One of the options is to show a log after every sync (if desired). If there is an error during
sync then the log dialog will always be shown.
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Organising added notes

During the sync, notes present in the Evernote notebook are added to the RightNote
notebook. This presents a bit of a problem! In Evernote, notes are organised by tags,
whereas in RightNote the notes are organised by folders/structure. So when notes are
added to RightNote, they will not be in any type of structure.

At first, you are likely going to want to group the notes together or select them, based on
the tags that have been assigned to them.

Open the Resource Panel (F9), and click on the Tags tab. If you right click on the tag list,
you will see an action: Select in Tree.
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Clicking on this will select all notes in the current page that have the selected tag.
Thereafter you can move the selected notes to a different location (e.g. a folder in another
page) using drag-and-drop, or the cut/paste commands available in the tree right-click
menu.

You may want to filter the tag search results to the current page, so that you can see more
clearly which notes will be selected, and the number of notes with the given tag in the
current page:
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Editing web clips

The Evernote note editor (in RightNote) allows you to create and edit notes that are
compatible with the Evernote note format. At the same time, it is worth noting that
RightNote is using a different editing engine from the Evernote desktop client. For simple
notes that you create in RightNote or Evernote this is likely to make little difference.
However when it comes to editing web clips this difference can become more noticeable.
Web clips that have been created/captured using the Evernote web clipper, preserve a large
amount of styling and layout information from the source page, and usually result in
complex Evernote notes.

Even though you can edit these notes in RightNote, doing so can sometimes lead to
problems. It's a bit like changing one piece of puzzle - it's hard to do that easily without
causing problems in nearby elements.

I was testing one webpage - captured with the Evernote web clipper, and editing it in
RightNote. After one small change, almost 80% of the page "disappeared". This turned out
to be a display problem - the note content was still all there. Under "Format" (menu item) I
pressed "Remove All Formatting". Then all of the webpage content returned and was
displayed, although some formatting was lost.

So therefore an option exists in the Evernote settings (in the Options dialog) to disable
editing of web clips by default. You can override this setting on a per note basis. The
intention is that it may work better to edit these notes in the Evernote Windows client
instead of in RightNote itself.

You can open the note in Evernote by clicking on the Open in Evernote button (green
arrow). (This note must of course exist in the Evernote client aswell). If you hold down
SHIFT while you click on the button and it opens in Evernote, the note will come up in the
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Evernote editor window.
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Clip to Evernote note

There is an option to clip to an Evernote note type. This can be set in the Clipper options
(under Tools).
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Notes for upgrading from v2

The way Evernote tokens are stored has been changed since version 2, so when upgrading
from version 2, you will need to enter your account details in the Evernote Manager
dialog, and obtain a token from there.

For notebooks that have been linked via the File Properties - Evernote section, there are 2
ways to proceed:

Option 1: You want this file to be the file that syncs with the Evernote notebook it has
been linked to.

For example: You have been syncing this file with Evernote, and it contains a number of
notes that have already been organised into a specific hierarchy.

Steps to take:

1. In the Evernote Manager, for the relevant account, place a tick next to the relevant
notebook. (i.e. you want it synced).
2. Press OK, to close the Evernote Manager.
3. Press Sync All. (Tools->Sync All) This will create the correct folder for the account, and
the relevant notebook.
4. Once the sync has started, you can press Stop, to stop the sync.
5. Open the Evernote storage folder (location is shown in the Evernote Manager settings
section), and locate the relevant file. You must replace/overwrite this file with your existing
file. If the existing file has/had a different name, you must rename it to the Evernote
notebook name that you see in the folder.

For example: Your file was named MyNoteBook.rnt, and it was syncing with an Evernote
notebook called General. You will see that when the sync started a file was created called
General.rnt (in the Evernote storage folder, in a sub folder for that account). So you need
to rename your notebook (MyNoteBook.rnt) to General.rnt, and then overwrite the file that
you see in the Evernote storage sub folder. (Of course, you could first delete the
automatically created file, and then move your file to that location and then rename it.)

If you are unsure of what you are doing, it is recommended that you first make a backup of
your existing file in case you have a problem when performing the above steps.

Option 2: You have setup a link between an existing RightNote file and an Evernote
notebook, but you don't mind starting again from scratch.

In this case you can remove the link from the existing file in the File Properties - Evernote
section (clear the Account and Notebook fields). Now when you perform a sync, a new file
will be created for the notebook in the Evernote storage folder.
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Current Limitations & Planned Features

This is the initial release of the Evernote integration feature, and so there are a few things
that have not been completely implemented yet. They are on the to-do list as well as
planned features mentioned below.

· So far you can only convert a Richview or RichEdit note to an Evernote note.
· The text color, background color and style toolbars should work in most cases, however

in some cases the formatting will be (slightly) modified to conform to the Evernote
content standards.

· When the Evernote editor has focus, other keyboard hotkeys do not work, e.g. Ctrl+S
does not work to save changes (you need to use the mouse to click on the save button).

· Evernote attachments and "locks" do store the actual information/attachment - however
at this point you cannot decrypt the protected text, or open/edit the attachment.
Warning: If you delete the picture (of the attachment/lock), this will delete the
attachment or protected text itself.

· On rare occassion the Evernote editor may get "stuck" so that when you move to
another Evernote note, the contents of the previous note remain. You can fix this by
moving to a non-Evernote note, e.g. click on a Richview note and then go back to the
Evernote note.

Planned features

· Improved sync speed
· ...
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Maximum & recommended database file size

This is certainly the most frequently asked question about RightNote.

There are 2 parts to this question:
i) What is the maximum database size, and
ii) What is the recommended database size.

Maximum database size

RightNote uses the open source SQLite database engine (www.sqlite.org) to store it's data,
which itself can handle very large files - i.e. TeraBytes. Within RightNote itself, there are no
specific limitations on number of pages per notebook, numbers of notes per page etc..,
however performance will be affected for very large files. 

It is more useful to speak about recommended database size so that you can: 1) understand
how RightNote is working in terms of file size, and 2) understand how best to use RightNote
so that performance is optimal.

Recommended database size

When you open a RightNote file, RightNote does not load all the file data. It only loads data
as it is needed. When you open a file, only the current page/tree will be loaded.
Additionally, note content is only loaded when you click on a note.

A page/tree will load quickly if it only has a few hundred notes. Once there are a few
thousand notes, you will see that loading time becomes slower. Bearing this in mind,
performance will be best if you spread your notes over a number of pages and notebooks. 

https://www.helpndoc.com/help-authoring-tool
http://www.sqlite.org
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As far as file size is concerned you should probably keep your file size in the MB range i.e.
less than 300 MB for best performance.
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How to share a database between multiple computers

Many people have the need or desire to use the same RightNote file on different computers.
There are many free file sharing services available nowadays, that can be used for this
purpose. Well known services include Dropbox (www.dropbox.com), OneDrive and Google
Drive.

In this topic we'll refer to Dropbox, however the same guidelines should apply for the other
mentioned services.

To set up the file sharing, perform the following steps:
· If you have not done so already, create a Dropbox account on their website.

· Download the Dropbox software, and install it on your computer.

· Setup Dropbox to use the above created account.

· Dropbox creates a special folder on your computer called Dropbox. You should place the
desired RightNote files (they end in *.rnt) somewhere under this folder.

· Next install the Dropbox software on your other computers. Once you enter your
account details, you will see that any files you have placed in the Dropbox folder (on
one of the other computers) will automatically be synced to this computer.

As you open Windows Explorer (Windows Key + E), you should quite easily to be able to
locate the Dropbox folder under Favorites:

Some important points to keep in mind when making use of a file sharing service:

· You should not use the same file on both computers at the same time.

https://www.helpndoc.com/feature-tour
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· The syncing service does not always work instantly. Sometimes it takes a while before
the file updates on other computers. It is very important that you only use a file on a
second computer (e.g. Computer B) after it has synced the changes made on Computer
A. If you are not careful about this you could lose some data in the process. (If you click
on the Dropbox system tray icon, it shows a short history of recent file syncs, so you can
use this to confirm if a sync has taken place or not).

· On rare occasions a file can become corrupt while Dropbox is trying to sync it. Therefore
it is important that you also keep some backups in place of your files. It is safer to keep
these backups in a folder that is not under the Dropbox folder.
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Causes of database corruption

What causes database corruption?

Under normal circumstances, it is quite rare for a database to become corrupted. RightNote
uses the industry standard, SQLite database engine to store its content. The SQLite engine
has various features to help prevent database corruption.

That being said, it is still possible for a database file to become corrupt. A sudden loss of
power to the PC, or some hard drive malfunction can result in database corruption.
However, the most common cause of database corruption, is placing the file in a cloud sync
folder such as Dropbox, OneDrive or Google Drive. If the cloud service tries to sync the file
at the same time that RightNote is busy making some changes to the database, this could
result in database corruption. That is not to say that these services cannot and should not
be used, however it does mean that if you are using these services, you should pay
attention to the recommendations and best practices in this regard.

How do I know that a database has become corrupt?

Database corruption can show up in one of two ways:

1) You get a "database disk image is malformed" error message, when you try to open the
file.

2) In the second case, the database/file can be opened and viewed successfully, however a
similar error occurs when you try to save changes to the database. Or you can open and
view most of the database content, however an error occurs when you open a specific note.

The first case is more serious since you cannot even view the contents of the database.

Created with the Standard Edition of HelpNDoc: Free Web Help generator

3 ways to deal with a corrupt database

There are three ways to deal with or repair a corrupt database.

1) Fix the database with the repair tool

Try to repair the database with the repair database function, which can be found under File-
>Maintenance->Repair Database. See more info here: Using the repair database tool.

2) Revert to a backup copy of the database

By default RightNote creates backups of your databases, as per the Backup settings which
can be found under Main->Backup in the Options dialog (under Tools->Options). To
locate/open the backups folder, click on Help->Open Backups Folder.

https://www.helpndoc.com/create-epub-ebooks
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Look in the backups folder to see what backups are available for the file in question. To
check the "corruption status" of the backup files, do the following:

· Open the Folder Health Report dialog (under File->Maintenance->Folder Health Report)
· Right-click on the "Select Folder" button, then click on "Use Backup Folder".
· Click on "Process"

The result will indicate if there is a problem with the backup files. You may find a working
backup file, however, depending on how long ago this backup was created, you may want to
look at the other methods of dealing a corrupt file, i.e. if the backup file is from a while ago,
the other options mentioned, may be better solutions.

3) Manually transfer database contents to a new file

This method will only work if you are able to open the corrupted file, i.e. there is a problem
accessing specific pages or notes, or an error occurs when saving.

The idea is to move/copy over as much content as possible from the corrupt database to a
fresh new file.

Perform the following steps:

· Create a new database file
· Use the "Page Transfer Tool" (under Tools) to sequentially copy each page from the

problem notebook to the new notebook. (The dialog contains usage instructions at the
top). After copying each page press "Save". If the save completes without any error,
then you know that page has no errors, and has been successfully copied over to the
new database. If however, you encounter an error when you press "Save", then you
know that page contains some corrupted notes. So to deal with this problem page,
continue to the next step...

· Now use the "Floating Tree" tool (also under Tools) to sequentially copy over notes
from the problem page to a page in the new notebook, i.e. perform the following steps:

a. First open the new notebook (in the main RightNote interface), and add a new
page. Rename the page to the name of the problem page in the old notebook.

b. Now click on Tools->Floating Tree
c. Click on "Open Notebook", and select the corrupt database.
d. In the drop down select the problem page
e. Now select a number of notes in the Floating tree, and copy them (Shift+Ctrl+C).
f. Click on the tree of the corresponding page in the new notebook (i.e. open in the

main RightNote window), and paste (Shift+Ctrl+V).
g. So now the same logic will apply as mentioned above for the page transfer: If

you can copy/paste those notes without any error into the new notebook, then
you know there is no problem with those notes. However, if some error occurs
when you try to copy the notes, then you know there is a problem with those
notes.

h. I say to select and copy "notes" (in plural) because that will make the process
quicker and save you time. However, once you encounter a problem, then you
should perform the select/copy/paste steps for individual notes until you locate
the specific problem note(s).

i. That's it. You have successfully copied over as much content as possible, from the
corrupt database to a fresh new database.
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Recommendations and best practices when using cloud services

Keep in mind the following recommendations when placing your database files in a cloud
syncing folder, such as Dropbox or OneDrive. For the sake of brevity, in the points below I
will refer to the Dropbox service, however the same applies to other services.

1) My understanding is that database corruption becomes more likely when RightNote and
Dropbox are trying to access the database file at the same time. As such, refrain from using
the file when you can see that Dropbox is busy syncing. So for example, make some
changes to the file, press Save, then wait for Dropbox to complete syncing the changes,
before doing anything further with the File. (Under normal circumstances, this should be
only a couple of seconds).

2) Keep your data in a few small to medium size files, instead of all your data in a single
large database file. The idea here is to not put "all your eggs in one basket". If a database
becomes corrupted, and all your data is in that single file, it will obviously spell more
trouble than if you have split your data over more than one file. Also, smaller files are
easier to keep multiple backups of, and the backup operation will be quicker.

3) Increase the number of backup files to keep (under Tools->Options->Main->Backup). I
recommend keeping your backups on the local hard drive. Again, don't keep all your egg in
one basket.

4) If you have a slow or flaky internet connection, pay special attention to point no. 1)
above.

Created with the Standard Edition of HelpNDoc: Easily create Web Help sites

Tips
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Using RightNote in a home network

RightNote includes various options that can allow a single user to use the application and
work with the same file across a network connection.

Steps to take when all computers are running windows:

1.  Place the RightNote file you intend to access from the different computers in a shared
network folder.

2.  Enable the "autosave after X minutes" option, to make sure that your latest work is
always saved to file before moving to another computer (Saving and Backup settings).
Set the time interval to 1 minute.

After you make changes to a notebook at one computer, your work should have been saved
by the time you get to the next (or other) computer. You should then get a message "The
file you are working on has been modified by another process..etc.. and should be
reloaded..". Click OK to reload the file.

You can also disable this prompt (see Confirmations -> "Confirm reload file after file
changed by another process") to have RightNote automatically reload files when it detects a
change from another process (i.e. your work from the other computer).

If for some reason you don't reload a file after changes have been made to it from another
computer, then, depending on the changes made at each computer, you may or may not
encounter an error message when trying to save your work. In a worst case scenario, you

https://www.helpndoc.com/feature-tour
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will lose the changes made (on the more "recent" computer) since the last save. See
Running multiple instances for more information.

When the shared file resides on a Samba network drive:

If the shared file resides on a samba network drive, then follow the same steps as above -
plus enable the "Check for file writes over Samba network drives" option in the Saving and
Backup settings section, to obtain the same effect.

Created with the Standard Edition of HelpNDoc: Full-featured Help generator

Issues

Created with the Standard Edition of HelpNDoc: Free EBook and documentation generator

Encryption issue and fix

Please note that a bug related to the encryption mechanism crept into the program at
version 3.2.0.

This bug affected notes in a protected page. It did not affect individual notes that were
protected or entire notebooks that were protected with a file password.

The bug itself was fixed in version 3.5.0. However, any notebook with a protected page that
was modified during this period (i.e from version 3.2 to 3.5), needs to be re-protected. 

You can do this in one of two ways:

1. Run the "Re-Save Entire File" action found under Help->Debug, or

2. For each protected page:
- Select to unprotect it (Protect -> No)
- Save notebook
- Select to protect (Protect -> Yes)
- Save notebook

Created with the Standard Edition of HelpNDoc: Create cross-platform Qt Help files

Evernote reminders automatically created in Web/Android client

There was a bug in the Evernote integration where simply creating a new note in RightNote
- without any reminder - when synced, would result in a reminder being created in the Web
and Android Evernote clients. Strangely enough no reminder was visible in the Evernote
Windows client. There seemed to be some inconsistency in the Evernote implementations.

This issue has been fixed in v3.5.5.

To remove these unwanted reminders, click on Help->Debug->Touch Evernote Notes.

This will set all Evernote notes in the current notebook as modified. When you sync, the
reminders will be removed.

Notes:
1) All notes in the notebook will need to be re-synced. However only the meta-data is re-
synced - not the note content, so it will be quicker.
2) You need to perform this action (Touch Evernote Notes) for each notebook that you want
to fix.
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Feature comparison between different versions
Here is an overview of differences between the various versions of RightNote:

Freeware version:

- Includes the following note types:
o Rich text note which supports basic text formatting capabilities (like Wordpad)
o Source code note - includes highlighters for many common programming

languages
o Memo note for plain text notes
o Link note type - quick and easy access to related files on your hard- disk

- Rich text note includes a pre-defined styles tool as well as text highlighting tools.
- Live search: see search results as you type.
- Highlighted search results: Easily see which search result to focus on.
- Note protection: encrypt content of selected notes with industry standard AES encryption.
- Includes huge icon collection (for tree nodes and tags) as well as ability to add your own
icons.
- Powerful tagging system allows you to classify your notes in varying ways.
- Assign icons to tags so that notes in the tree can be highlighted and "stand out"
- Import and export notes to common formats
- Favorites toolbar for quick access to frequently used files.
- Easily transfer pages and notes between files using the page transfer and floating tree
tools
- Screen capture tool allows you to save screen clips into your notes.
- Clip plain text from other applications into RightNote with global clipper hotkey.
- Portable (USB) and installable versions available.
- Evernote note type.
- Free for both personal and commercial use.

Standard version:

- All features of Freeware version plus:
- Rich view note type: supports advanced text editing capabilites including multiple image
support, advanced table support, advanced paragraph layout and formatting, pre-defined
text and paragraph style tools
- Spell checker (for Rich view note)
- Spreadsheet note type: supports most excel functions, ability to sort columns, fill
command, fixed header row, merge/split cells, cell comments, cell links and images
- Import from and export to MS Excel files
- Create links to other notes (Richview and spreadsheet notes)
- Attachment note type - store any type of file in a RightNote database (file)
- Advanced clipper functionality: include styles and images in clips from web-pages

Professional version:

- All features of the Standard version plus:
- Index contents of attachment note types. Support for txt, rtf, htm, html, pdf, doc, docx,
csv, xls and xlsx file types.
- Multi-note book search: search through all your notebooks instantly.
- Save web-pages to a web-page note.
- Export notes to both web-based and mobile-based webbooks.
- Side by side view: easily transfer notes between pages in the same or different notebooks.
- Evernote Manager allows you to easily manage multiple Evernote accounts and notebooks.
- Sync Evernote notes with your Evernote account.
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- Journal feature
- Insert Youtube Playlist, Video Transcript & Description
- Insert Bookmarks
- Split Tree view
- Side Tree view
- Templates
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Portable version
Two portable versions of RightNote are available from the website download page
(http://bauerapps.com/downloads/):

· RightNotePortableSetup.exe (includes an installer program to install the portable
version)

· RightNote.zip (a standard zip archive. Requires you to unzip the file to a folder of your
choice)

Advantages of the portable version

Application settings are saved under the application folder.

· The most recently used file list adjusts itself as the portable media drive letter
changes. For example, if on one occasion your USB stick is allocated drive "F:" and you
work on a file "F:\My RightNote Files\MyNotes.rnt", and then the next time you run
RightNote your USB stick happens to be on drive "G:", then RightNote will automatically
adjust the file path and open "G:\My RightNote Files\MyNotes.rnt" or show this path in
the recently opened file list.

· The same applies for the global backup folder (Options->Backup settings). The backup
path will adjust as the portable media drive letter changes.

· When you enter your registration details into the "Enter Key" dialog, a license file is
generated in the application folder, which stores your registration information, so you
don't need to enter this information as you move to another computer.

· You can run the installer file (RightNotePortableSetup.exe) to a portable medium (e.g.
USB stick) and then safely use the application on other people's machines without
interfering with any of their settings, and without the need for registering the
application on their computer.

Unzipping the zip archive

The first time you unzip the archive, extract to a folder of your choice. Then click on
"RightNote.exe" to run the program. When you download newer versions of RightNote
(RightNote.zip), you will want to unzip the archive to the same location each time. When
extracting you should be prompted by your zip utility: "Do you want to overwrite existing
file xyz" etc. You should say "Yes" each time, or "Yes to All". In this way the files that need
to be updated will be updated, however your settings files will not be affected.

Important: The RightNote New User Guide (RNUserGuide.rnt) file will be overwritten each
time you extract the zip archive. Do not store your own notes in this file.

Note:

https://www.helpndoc.com
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The portable version does temporarily store some settings in the registry of the host
computer, however these are deleted when the application closes.
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Support

Feedback

We're very interested to hear from you, what you think about RightNote so please drop us
an email at the address mentioned below. What do you like? What don't you like? What
features would you like to see included in the next version?

Bug reports

If you happen to experience something not working as you think it should be, or you are
getting frank error messages, please let us know about this, and we will try to fix  them as
soon as possible. The most useful information for a bug report is including the exact steps
required to consistently reproduce the behaviour you are experiencing. This makes it alot
easier to get to the root of the problem.

All correspondence should be sent to:
support@bauerapps.com

Note:
Please include the term "Bauerapps" or "RightNote" in either the subject or body of your
message to bypass spam filters. Thank you.

Created with the Standard Edition of HelpNDoc: Easily create EBooks

Ordering

RightNote offers a 30 day trial evaluation period which allows you to see for yourself
whether you would like to purchase the program or not.

If you would like to continue using the software after the trial period has expired you need
to purchase a license. To do this, follow the links on our site at:
http://bauerapps.com/rightnote-pricing/
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Credits

RightNote makes use of some excellent third-party controls. Thank you to the authors of
these components for making them available to the public:

· Jordan Russel - TB2000

· Robert Lee - SpTBXLib package for TB2000

· Jedi VCL - Jedi Visual Component Library

· Jim Kueneman - EasyListView
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· Lasse Markus Rautiainen - TTextEditor

· Some icons are from FatCow Icons 

Thanks also to those users who have sent in valuable feedback in the form of feature
suggestions and bug reports. This feedback has helped improve the application in significant
ways. Thank you!
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PDF Version

A PDF version of the help file can be downloaded from here:
http://www.bauerapps.com/files/RightNote.pdf
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